summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-08-29 13:00:37 +0000
committerMarinus Schraal <foser@gentoo.org>2004-08-29 13:00:37 +0000
commit3733f5c6ada7671d50b903e88ee5d89f07dea6a6 (patch)
treed1ff8032ebacc6462a61b1df9d903b6711df2590 /x11-libs
parentnew release 'n cleanup (diff)
downloadhistorical-3733f5c6ada7671d50b903e88ee5d89f07dea6a6.tar.gz
historical-3733f5c6ada7671d50b903e88ee5d89f07dea6a6.tar.bz2
historical-3733f5c6ada7671d50b903e88ee5d89f07dea6a6.zip
what a lib64 mess
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/Manifest2
-rw-r--r--x11-libs/gtk+/gtk+-2.4.9.ebuild22
2 files changed, 19 insertions, 5 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index c5a86ca4ad07..ecdbc4a63375 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,7 +1,7 @@
MD5 264f07045948900c7457af906640d922 gtk+-1.2.10-r11.ebuild 1792
MD5 4b173bf958771b902f94c9bf0702ad7f gtk+-2.4.7.ebuild 3037
MD5 745da6d8feb5c80670d33a3c43400bf5 gtk+-1.2.10-r10.ebuild 1719
-MD5 19f117add72884eacaac0247f412d0bd gtk+-2.4.9.ebuild 2267
+MD5 ae56a7aa77f278f2ed2eaf5cff5496bd gtk+-2.4.9.ebuild 3040
MD5 dbb1344671d8e80b211625c3d67e76c7 gtk+-2.4.4.ebuild 2990
MD5 6880289256085cb8cb69a597d8098333 gtk+-2.4.1.ebuild 2238
MD5 c0a4cd06bd9eccc2c94b6527ab8ef3a2 ChangeLog 18153
diff --git a/x11-libs/gtk+/gtk+-2.4.9.ebuild b/x11-libs/gtk+/gtk+-2.4.9.ebuild
index e0ecc57d2d68..773de4cae700 100644
--- a/x11-libs/gtk+/gtk+-2.4.9.ebuild
+++ b/x11-libs/gtk+/gtk+-2.4.9.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.9.ebuild,v 1.1 2004/08/29 12:50:08 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.9.ebuild,v 1.2 2004/08/29 13:00:37 foser Exp $
inherit libtool flag-o-matic eutils
DESCRIPTION="Gimp ToolKit +"
HOMEPAGE="http://www.gtk.org/"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.4/${P}.tar.bz2"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.4/${P}.tar.bz2
+ amd64? ( http://dev.gentoo.org/~lv/gtk+-2.4.1-lib64.patch.bz2 )"
LICENSE="LGPL-2"
SLOT="2"
@@ -40,8 +41,15 @@ src_unpack() {
# add smoothscroll support for usability reasons
# http://bugzilla.gnome.org/show_bug.cgi?id=103811
epatch ${FILESDIR}/${PN}-2.4-smoothscroll.patch
+ # use an arch-specific config directory so that 32bit and 64bit versions
+ # dont clash on multilib systems
+ use amd64 && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
autoconf || die
+ automake || die
}
@@ -69,6 +77,8 @@ src_compile() {
src_install() {
dodir /etc/gtk-2.0
+ use amd64 && dodir /etc/gtk-2.0/${CHOST}
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && dodir /etc/gtk-2.0/${CHOST}
make DESTDIR=${D} install || die
@@ -82,8 +92,12 @@ src_install() {
pkg_postinst() {
- gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
- gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
+ use amd64 && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+
+ gtk-query-immodules-2.0 > /${GTK2_CONFDIR}/gtk.immodules
+ gdk-pixbuf-query-loaders > /${GTK2_CONFDIR}/gdk-pixbuf.loaders
einfo "For gtk themes to work correctly after an update, you might have to rebuild your theme engines."
einfo "Executing 'qpkg -f -nc /usr/lib/gtk-2.0/2.2.0/engines | xargs emerge' should do the trick if"