summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-09-14 08:12:03 +0000
committerBen de Groot <yngwin@gentoo.org>2012-09-14 08:12:03 +0000
commit40efd321f27b3afdde87cafd5b9109f88260b59c (patch)
treeec659f69e0a961915a7f641791588fed0894dba0 /x11-libs/qt-openvg
parentVersion bump. (diff)
downloadhistorical-40efd321f27b3afdde87cafd5b9109f88260b59c.tar.gz
historical-40efd321f27b3afdde87cafd5b9109f88260b59c.tar.bz2
historical-40efd321f27b3afdde87cafd5b9109f88260b59c.zip
Version bump. Drop qatomic-x32 patch applied upstream. Drop qpa useflag.
Package-Manager: portage-2.2.0_alpha128/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-openvg')
-rw-r--r--x11-libs/qt-openvg/ChangeLog7
-rw-r--r--x11-libs/qt-openvg/qt-openvg-4.8.3.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/x11-libs/qt-openvg/ChangeLog b/x11-libs/qt-openvg/ChangeLog
index 0bd98bb6e6c0..9a5563cbe4b9 100644
--- a/x11-libs/qt-openvg/ChangeLog
+++ b/x11-libs/qt-openvg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-openvg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-openvg/ChangeLog,v 1.13 2012/07/15 10:55:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-openvg/ChangeLog,v 1.14 2012/09/14 08:12:03 yngwin Exp $
+
+*qt-openvg-4.8.3 (14 Sep 2012)
+
+ 14 Sep 2012; Ben de Groot <yngwin@gentoo.org> +qt-openvg-4.8.3.ebuild:
+ Version bump. Drop qatomic-x32 patch applied upstream. Drop qpa useflag.
15 Jul 2012; Agostino Sarubbo <ago@gentoo.org> qt-openvg-4.8.2.ebuild:
Stable for x86, wrt bug #424625
diff --git a/x11-libs/qt-openvg/qt-openvg-4.8.3.ebuild b/x11-libs/qt-openvg/qt-openvg-4.8.3.ebuild
new file mode 100644
index 000000000000..df1999279209
--- /dev/null
+++ b/x11-libs/qt-openvg/qt-openvg-4.8.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-openvg/qt-openvg-4.8.3.ebuild,v 1.1 2012/09/14 08:12:03 yngwin Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The OpenVG module for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+IUSE="qt3support"
+
+DEPEND="
+ media-libs/mesa[egl,openvg]
+ ~x11-libs/qt-core-${PV}[aqua=,c++0x=,debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,c++0x=,debug=,egl,qt3support=]
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/openvg
+ src/plugins/graphicssystems/openvg"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtGui
+ include/QtOpenVG
+ src/corelib
+ src/gui
+ src/openvg
+ src/plugins
+ src/3rdparty"
+
+ QCONFIG_ADD="openvg"
+ QCONFIG_DEFINE="QT_OPENVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ gltype="desktop"
+
+ myconf+="
+ -openvg -egl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+
+ # touch the available graphics systems
+ dodir /usr/share/qt4/graphicssystems
+ echo "experimental" > "${ED}"/usr/share/qt4/graphicssystems/openvg || die
+}