summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-23 00:44:14 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-23 00:44:14 +0000
commit661c420f2a5cc510e561cc6bcd5766f4bc7b4076 (patch)
tree4e9d029a1bc8bd911b97101f6f7a240738ed6596 /x11-libs/libast
parentpermission fix #37879 (diff)
downloadhistorical-661c420f2a5cc510e561cc6bcd5766f4bc7b4076.tar.gz
historical-661c420f2a5cc510e561cc6bcd5766f4bc7b4076.tar.bz2
historical-661c420f2a5cc510e561cc6bcd5766f4bc7b4076.zip
dont use imlib if -X is in USE #38596
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/ChangeLog7
-rw-r--r--x11-libs/libast/files/digest-libast-0.5-r2 (renamed from x11-libs/libast/files/digest-libast-0.5-r1)0
-rw-r--r--x11-libs/libast/libast-0.5-r2.ebuild (renamed from x11-libs/libast/libast-0.5-r1.ebuild)12
3 files changed, 14 insertions, 5 deletions
diff --git a/x11-libs/libast/ChangeLog b/x11-libs/libast/ChangeLog
index 4e87b052c3cb..938b47c58c35 100644
--- a/x11-libs/libast/ChangeLog
+++ b/x11-libs/libast/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libast
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.8 2003/04/09 15:50:10 todd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.9 2004/02/23 00:44:14 vapier Exp $
+
+*libast-0.5-r2 (22 Feb 2004)
+
+ 22 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Don't enable imlib if X is not in USE #38596.
*libast-0.5-r1 (20 Mar 2003)
diff --git a/x11-libs/libast/files/digest-libast-0.5-r1 b/x11-libs/libast/files/digest-libast-0.5-r2
index 18efb6adbbc9..18efb6adbbc9 100644
--- a/x11-libs/libast/files/digest-libast-0.5-r1
+++ b/x11-libs/libast/files/digest-libast-0.5-r2
diff --git a/x11-libs/libast/libast-0.5-r1.ebuild b/x11-libs/libast/libast-0.5-r2.ebuild
index dd73fd6f5077..5288ac4fb2db 100644
--- a/x11-libs/libast/libast-0.5-r1.ebuild
+++ b/x11-libs/libast/libast-0.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r1.ebuild,v 1.10 2004/02/17 08:09:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r2.ebuild,v 1.1 2004/02/23 00:44:14 vapier Exp $
DESCRIPTION="LIBrary of Assorted Spiffy Things"
HOMEPAGE="http://www.eterm.org/download/"
@@ -9,16 +9,20 @@ SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc alpha sparc alpha hppa ~amd64"
-IUSE="imlib mmx perl"
+IUSE="X imlib mmx perl"
DEPEND="virtual/x11
=media-libs/freetype-1*
- imlib? ( media-libs/imlib2 )
+ X? ( imlib? ( media-libs/imlib2 ) )
perl? ( dev-libs/libpcre )"
src_compile() {
+ local myconf
+ use X && use imlib \
+ && myconf="--with-imlib" \
+ || myconf="--without-imlib"
econf \
- `use_with imlib` \
+ ${myconf} \
`use_enable mmx` \
|| die
emake || die