summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-02-09 15:20:09 +0000
committerJeroen Roovers <jer@gentoo.org>2013-02-09 15:20:09 +0000
commitd290d125e5ee72b00a26938bf35b264576a271a6 (patch)
treea95803bcc17a2653beb10eda17d138b597924be4 /x11-libs/gtkdatabox/gtkdatabox-0.9.2.0.ebuild
parentVersion bump - bug #455112 (diff)
downloadhistorical-d290d125e5ee72b00a26938bf35b264576a271a6.tar.gz
historical-d290d125e5ee72b00a26938bf35b264576a271a6.tar.bz2
historical-d290d125e5ee72b00a26938bf35b264576a271a6.zip
Version bump (bug #383465).
Package-Manager: portage-2.1.11.50/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/gtkdatabox/gtkdatabox-0.9.2.0.ebuild')
-rw-r--r--x11-libs/gtkdatabox/gtkdatabox-0.9.2.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/gtkdatabox/gtkdatabox-0.9.2.0.ebuild b/x11-libs/gtkdatabox/gtkdatabox-0.9.2.0.ebuild
new file mode 100644
index 000000000000..d3b8ce6d57ea
--- /dev/null
+++ b/x11-libs/gtkdatabox/gtkdatabox-0.9.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkdatabox/gtkdatabox-0.9.2.0.ebuild,v 1.1 2013/02/09 15:20:07 jer Exp $
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="Gtk+ Widgets for live display of large amounts of fluctuating numerical data"
+HOMEPAGE="http://sourceforge.net/projects/gtkdatabox/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +glade static-libs test"
+
+RDEPEND="
+ glade? (
+ dev-util/glade:3
+ gnome-base/libglade
+ )
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/pango
+"
+DEPEND=${RDEPEND}
+
+src_prepare() {
+ # Remove -D.*DISABLE_DEPRECATED cflags
+ find . -iname 'Makefile.am' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die "sed 1 failed"
+ # Do Makefile.in after Makefile.am to avoid automake maintainer-mode
+ find . -iname 'Makefile.in' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die "sed 2 failed"
+ sed -e '/SUBDIRS/{s: examples::;}' -i Makefile.am -i Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable glade libglade) \
+ $(use_enable glade) \
+ $(use_enable static-libs static) \
+ $(use_enable test gtktest) \
+ --disable-dependency-tracking \
+ --enable-libtool-lock
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ dodoc AUTHORS ChangeLog README TODO
+ if use examples; then
+ docinto examples
+ dodoc "${S}"/examples/*
+ fi
+}