summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-03-04 23:05:33 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-03-04 23:05:33 +0000
commit285eb3f680075250053af78db9cb371df2aba091 (patch)
tree6e76edff2b0e1ee08cf4911f179c9ab7a538b3b4 /x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild
parentVersion bump. (diff)
downloadhistorical-285eb3f680075250053af78db9cb371df2aba091.tar.gz
historical-285eb3f680075250053af78db9cb371df2aba091.tar.bz2
historical-285eb3f680075250053af78db9cb371df2aba091.zip
Version bump.
Package-Manager: portage-2.2.0_alpha24/cvs/Linux x86_64
Diffstat (limited to 'x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild')
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild
new file mode 100644
index 000000000000..5a198d07ea79
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild,v 1.1 2011/03/04 23:05:33 scarabeus Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=x11-base/xorg-server-1.8
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ >=x11-proto/recordproto-1.14"
+
+DOCS=( "README" )
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}