summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2007-03-14 18:18:53 +0000
committerBryan Stine <battousai@gentoo.org>2007-03-14 18:18:53 +0000
commit4f3baee45d7c438f971e6e317bce079fd29bbe8f (patch)
treeb15490ae119e6fe6069c3b40c18c97510e9fc974 /x11-base/x11-drm/x11-drm-20070314.ebuild
parentRemoved opengl-update for bug #170889. (diff)
downloadhistorical-4f3baee45d7c438f971e6e317bce079fd29bbe8f.tar.gz
historical-4f3baee45d7c438f971e6e317bce079fd29bbe8f.tar.bz2
historical-4f3baee45d7c438f971e6e317bce079fd29bbe8f.zip
Various ebuild fixes. Resolves bug #150957 and bug #170842.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'x11-base/x11-drm/x11-drm-20070314.ebuild')
-rw-r--r--x11-base/x11-drm/x11-drm-20070314.ebuild36
1 files changed, 15 insertions, 21 deletions
diff --git a/x11-base/x11-drm/x11-drm-20070314.ebuild b/x11-base/x11-drm/x11-drm-20070314.ebuild
index 9857d53f7191..54785838ce5a 100644
--- a/x11-base/x11-drm/x11-drm-20070314.ebuild
+++ b/x11-base/x11-drm/x11-drm-20070314.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20070314.ebuild,v 1.1 2007/03/14 17:08:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20070314.ebuild,v 1.2 2007/03/14 18:18:53 battousai Exp $
-inherit eutils x11 linux-mod
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.7"
+
+inherit eutils x11 linux-mod autotools
IUSE_VIDEO_CARDS="
video_cards_i810
@@ -20,7 +23,7 @@ IUSE="${IUSE_VIDEO_CARDS} kernel_FreeBSD kernel_linux"
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
-RESTRICT="nostrip"
+RESTRICT="strip"
S="${WORKDIR}/drm"
PATCHVER="0.1"
@@ -36,14 +39,10 @@ SLOT="0"
LICENSE="X11"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
-DEPEND=">=sys-devel/automake-1.7
- >=sys-devel/autoconf-2.59
- >=sys-devel/libtool-1.5.14
- >=sys-devel/m4-1.4
- kernel_linux? ( virtual/linux-sources )
+DEPEND="kernel_linux? ( virtual/linux-sources )
kernel_FreeBSD? ( sys-freebsd/freebsd-sources
- sys-freebsd/freebsd-mk-defs )
- >=sys-apps/portage-2.0.49-r13"
+ sys-freebsd/freebsd-mk-defs )"
+RDEPEND=""
pkg_setup() {
# Setup the kernel's stuff.
@@ -78,7 +77,7 @@ src_unpack() {
src_unpack_os
cd ${S}
- WANT_AUTOCONF="2.5" WANT_AUTOMAKE="1.7" autoreconf -v --install
+ eautoreconf -v --install
}
src_compile() {
@@ -132,7 +131,7 @@ kernel_setup() {
K_RV=${CHOST/*-freebsd/}
elif use kernel_linux
then
- get_version
+ linux-mod_pkg_setup
if kernel_is 2 4
then
@@ -141,17 +140,11 @@ kernel_setup() {
die "Please use in-kernel DRM or switch to a 2.6 kernel."
fi
- if linux_chkconfig_builtin "DRM"
- then
+ linux_chkconfig_builtin "DRM" && \
die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
- fi
- if ! linux_chkconfig_present "AGP"
- then
- einfo "AGP support is not enabled in your kernel config. This may be needed for DRM to"
- einfo "work, so you might want to double-check that setting. (CONFIG_AGP)"
- echo
- fi
+ CONFIG_CHECK="AGP"
+ ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
fi
}
@@ -314,6 +307,7 @@ src_install_linux() {
DESTDIR="${D}" \
RUNNING_REL="${KV_FULL}" \
MODULE_LIST="${VIDCARDS} ${DRM_KMOD}" \
+ O="${KBUILD_OUTPUT}" \
install || die "Install failed."
# Strip binaries, leaving /lib/modules untouched (bug #24415)