summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-06-22 21:45:24 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-06-22 21:45:24 +0000
commit0add63b33d46f009bcd925b207f6c4f5b2d0d99b (patch)
tree6c0efab9b17308db0d7bc3dcbb6688115af1c144 /x11-apps/grandr/grandr-0.1.ebuild
parentMarked ~hppa (bug #182551). (diff)
downloadhistorical-0add63b33d46f009bcd925b207f6c4f5b2d0d99b.tar.gz
historical-0add63b33d46f009bcd925b207f6c4f5b2d0d99b.tar.bz2
historical-0add63b33d46f009bcd925b207f6c4f5b2d0d99b.zip
Add new GTK+-based tool to configure the X output using the RandR 1.2 extension. Includes 2 patches from upstream git, and one typo fix that isn't upstream yet.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'x11-apps/grandr/grandr-0.1.ebuild')
-rw-r--r--x11-apps/grandr/grandr-0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-apps/grandr/grandr-0.1.ebuild b/x11-apps/grandr/grandr-0.1.ebuild
new file mode 100644
index 000000000000..226612f8bcff
--- /dev/null
+++ b/x11-apps/grandr/grandr-0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/grandr/grandr-0.1.ebuild,v 1.1 2007/06/22 21:45:24 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="GTK+-based tool to configure the X output using the RandR 1.2 extension"
+KEYWORDS="~ppc ~x86"
+LICENSE="MIT"
+RDEPEND="=x11-libs/gtk+-2*
+ >=x11-libs/libXrandr-1.2"
+DEPEND="${RDEPEND}"
+PATCHES="${FILESDIR}/${PV}-fix-license-display.patch
+ ${FILESDIR}/${PV}-outpus.patch
+ ${FILESDIR}/${PV}-fix-segfault-without-gconf-value.patch"
+
+src_install() {
+ x-modular_src_install
+ dodoc NEWS
+}