summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-07 16:55:37 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-07 16:55:37 +0000
commitaf3ac3984a154a6c56a78cdf81809ae193ab05a2 (patch)
treed503feee12d6988959125ab9bc7793764c0f814d /www-servers/pshs/pshs-0.2.4.ebuild
parentNew package, bug 445298. Ebuild by Matthew Reaume and Charles Nerot (diff)
downloadhistorical-af3ac3984a154a6c56a78cdf81809ae193ab05a2.tar.gz
historical-af3ac3984a154a6c56a78cdf81809ae193ab05a2.tar.bz2
historical-af3ac3984a154a6c56a78cdf81809ae193ab05a2.zip
Version bump. The new version fixes issues with broken connections causing program termination.
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0xEFB4464E!
Diffstat (limited to 'www-servers/pshs/pshs-0.2.4.ebuild')
-rw-r--r--www-servers/pshs/pshs-0.2.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/www-servers/pshs/pshs-0.2.4.ebuild b/www-servers/pshs/pshs-0.2.4.ebuild
new file mode 100644
index 000000000000..c363a977f8b1
--- /dev/null
+++ b/www-servers/pshs/pshs-0.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/pshs-0.2.4.ebuild,v 1.1 2014/12/07 16:55:35 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
+HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+magic +netlink qrcode upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable upnp)
+ )
+
+ autotools-utils_src_configure
+}