summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-03 10:48:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-03 10:48:08 +0000
commit822525333947d1ffd23d0c9e2bcfc40c24556468 (patch)
treeda8c3e032fb93508007cc6bc30673ea17ce29b04 /www-apache/mod_dnssd/mod_dnssd-0.6.ebuild
parentFix bug 268390 : unrecognised options --enable-debug (diff)
downloadhistorical-822525333947d1ffd23d0c9e2bcfc40c24556468.tar.gz
historical-822525333947d1ffd23d0c9e2bcfc40c24556468.tar.bz2
historical-822525333947d1ffd23d0c9e2bcfc40c24556468.zip
Bump to 0.6. Fix linking, bug #266433.
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'www-apache/mod_dnssd/mod_dnssd-0.6.ebuild')
-rw-r--r--www-apache/mod_dnssd/mod_dnssd-0.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/www-apache/mod_dnssd/mod_dnssd-0.6.ebuild b/www-apache/mod_dnssd/mod_dnssd-0.6.ebuild
new file mode 100644
index 000000000000..a061e0e94eba
--- /dev/null
+++ b/www-apache/mod_dnssd/mod_dnssd-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_dnssd/mod_dnssd-0.6.ebuild,v 1.1 2009/05/03 10:48:08 eva Exp $
+
+EAPI="2"
+
+inherit apache-module eutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="mod_dnssd is an Apache module which adds Zeroconf support via DNS-SD using Avahi"
+HOMEPAGE="http://0pointer.de/lennart/projects/mod_dnssd/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="net-dns/avahi[dbus]"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="80_${PN}"
+APACHE2_MOD_DEFINE="DNSSD"
+
+need_apache2
+
+src_prepare() {
+ # Respect LDFLAGS and use LIBS properly.
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
+src_configure() {
+ econf --with-apxs=${APXS} --disable-lynx
+}
+
+# Do not use inherited src_compile since it doesn't do what we want
+src_compile() {
+ emake || die "emake failed"
+}