summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-07 06:59:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-07 06:59:37 +0000
commitb32cd64ff26a074346c665bdeb6efc064f3f718e (patch)
tree0835c957c112dda705c2ca3ebe69c2c24fe4812d /sys-process/daemontools/daemontools-0.76-r7.ebuild
parentInitial import, based on ebuild in the science overlay. (diff)
downloadhistorical-b32cd64ff26a074346c665bdeb6efc064f3f718e.tar.gz
historical-b32cd64ff26a074346c665bdeb6efc064f3f718e.tar.bz2
historical-b32cd64ff26a074346c665bdeb6efc064f3f718e.zip
Fix ancient bug #86562.
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64
Diffstat (limited to 'sys-process/daemontools/daemontools-0.76-r7.ebuild')
-rw-r--r--sys-process/daemontools/daemontools-0.76-r7.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-process/daemontools/daemontools-0.76-r7.ebuild b/sys-process/daemontools/daemontools-0.76-r7.ebuild
new file mode 100644
index 000000000000..fe615a757a7d
--- /dev/null
+++ b/sys-process/daemontools/daemontools-0.76-r7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools/daemontools-0.76-r7.ebuild,v 1.1 2008/12/07 06:59:37 robbat2 Exp $
+
+inherit eutils flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="http://cr.yp.to/daemontools.html"
+SRC_URI="http://cr.yp.to/daemontools/${P}.tar.gz
+ http://smarden.org/pape/djb/manpages/${P}-man-20020131.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux static"
+
+DEPEND=""
+RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+ !app-doc/daemontools-man"
+
+S="${WORKDIR}"/admin/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-warnings.patch
+ ht_fix_file Makefile print-{cc,ld}.sh
+
+ use static && append-ldflags -static
+ qmail_set_cc
+}
+
+src_compile() {
+ touch home
+ emake || die
+}
+
+src_install() {
+ keepdir /service
+
+ dobin $(<../package/commands) || die
+ dodoc CHANGES ../package/README TODO
+ doman "${WORKDIR}"/${PN}-man/*.8
+
+ newinitd "${FILESDIR}"/svscan.init-0.76-r7 svscan
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can run daemontools using the svscan init.d script,"
+ einfo "or you could run it through inittab."
+ einfo "To use inittab, emerge supervise-scripts and run:"
+ einfo "svscan-add-to-inittab"
+ einfo "Then you can hup init with the command telinit q"
+ einfo
+}