summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-09-24 18:35:12 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-09-24 18:35:12 +0000
commitfdb9cca2b86197ce163790067d3749dd667e69ce (patch)
tree12b71a4ac315ee7e56d02e87b94c725ce9518a8b /sys-libs
parentI had the symlinks wrong, hee haw. (diff)
downloadhistorical-fdb9cca2b86197ce163790067d3749dd667e69ce.tar.gz
historical-fdb9cca2b86197ce163790067d3749dd667e69ce.tar.bz2
historical-fdb9cca2b86197ce163790067d3749dd667e69ce.zip
added 3.2.9
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/db-3.2.9.ebuild76
-rw-r--r--sys-libs/db/files/digest-db-3.2.91
-rw-r--r--sys-libs/db/files/patch.3.2.9.1104
-rw-r--r--sys-libs/db/files/patch.3.2.9.221
4 files changed, 202 insertions, 0 deletions
diff --git a/sys-libs/db/db-3.2.9.ebuild b/sys-libs/db/db-3.2.9.ebuild
new file mode 100644
index 000000000000..67bf6c224b92
--- /dev/null
+++ b/sys-libs/db/db-3.2.9.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9.ebuild,v 1.1 2001/09/24 18:35:12 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}/build_unix
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+SRC_URI="http://www.sleepycat.com/update/${PV}/${A}"
+HOMEPAGE="http://www.sleepycat.com/"
+
+RDEPEND="virtual/glibc"
+DEPEND="$RDEPEND =sys-libs/db-1.85-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/${P}
+ patch -p0 < ${FILESDIR}/patch.3.2.9.1
+ patch -p0 < ${FILESDIR}/patch.3.2.9.2
+}
+
+src_compile() {
+ ../dist/configure --host=${CHOST} --enable-compat185 --enable-dump185 --prefix=/usr --enable-shared --enable-static --enable-cxx || die
+ #--enable-rpc does not work
+ echo
+ # Parallel make does not work
+ echo "Building static libs..."
+ make libdb=libdb-3.2.a libdb-3.2.a || die
+ make libcxx=libdb_cxx-3.2.a libdb_cxx-3.2.a || die
+ echo
+ echo "Building db_dump185..."
+ /bin/sh ./libtool --mode=compile cc -c ${CFLAGS} -I/usr/include/db1 -I../dist/../include -D_REENTRANT ../dist/../db_dump185/db_dump185.c || die
+ gcc -s -static -o db_dump185 db_dump185.lo -L/usr/lib -ldb1 || die
+ echo
+ echo "Building everything else..."
+ make libdb=libdb-3.2.a libcxx=libdb_cxx-3.2.a || die
+}
+
+src_install () {
+ make libdb=libdb-3.2.a libcxx=libcxx_3.2.a prefix=${D}/usr install || die
+ dolib.a libdb-3.2.a libdb_cxx-3.2.a
+ dolib libdb-3.2.la libdb_cxx-3.2.la
+
+ dodir usr/include/db3
+ cd ${D}/usr/include
+ mv *.h db3
+ ln db3/db.h db.h
+
+ cd ${D}/usr/lib
+ ln -s libdb-3.2.so libdb.so.3
+
+ sed 's,installed=no,installed=yes,' < ${D}/usr/lib/libdb-3.2.la > ${D}/usr/lib/libdb-3.2.la.new
+ mv ${D}/usr/lib/libdb-3.2.la.new ${D}/usr/lib/libdb-3.2.la
+ sed 's,installed=no,installed=yes,' < ${D}/usr/lib/libdb_cxx-3.2.la > ${D}/usr/lib/libdb_cxx-3.2.la.new
+ mv ${D}/usr/lib/libdb_cxx-3.2.la.new ${D}/usr/lib/libdb_cxx-3.2.la
+
+ cd ${S}/..
+ dodoc README LICENSE
+ if [ -d ${D}/usr/share/doc/${PF} ]
+ then
+ mv ${D}/usr/docs ${D}/usr/share/doc/${PF}/html
+ else
+ mv ${D}/usr/docs ${D}/usr/doc/${PF}/html
+ fi
+ prepalldocs
+
+ #for some reason, db.so's are *not* readable by group or others, resulting in no one
+ #but root being able to use them!!! This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/lib
+ chmod go+rx *.so
+ #.la's aren't go readable either
+ chmod go+r *.la
+ #ok, everything should be fixed now :)
+}
+
diff --git a/sys-libs/db/files/digest-db-3.2.9 b/sys-libs/db/files/digest-db-3.2.9
new file mode 100644
index 000000000000..98304efe54dc
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.2.9
@@ -0,0 +1 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz
diff --git a/sys-libs/db/files/patch.3.2.9.1 b/sys-libs/db/files/patch.3.2.9.1
new file mode 100644
index 000000000000..8d70c6e51917
--- /dev/null
+++ b/sys-libs/db/files/patch.3.2.9.1
@@ -0,0 +1,104 @@
+*** include/log.h.orig 2001/01/25 18:22:51 11.20
+--- include/log.h 2001/02/06 05:02:28 11.21
+***************
+*** 198,203 ****
+--- 198,204 ----
+ */
+ typedef enum {
+ DB_LV_INCOMPLETE,
++ DB_LV_NONEXISTENT,
+ DB_LV_NORMAL,
+ DB_LV_OLD_READABLE,
+ DB_LV_OLD_UNREADABLE
+*** log/log.c.orig 2001/01/25 18:22:55 11.43
+--- log/log.c 2001/02/06 05:02:28 11.44
+***************
+*** 309,321 ****
+ int find_first, *valp;
+ logfile_validity *statusp;
+ {
+! logfile_validity clv_status, status;
+ u_int32_t clv, logval;
+ int cnt, fcnt, ret;
+ const char *dir;
+ char **names, *p, *q, savech;
+
+! clv_status = status = DB_LV_NORMAL;
+
+ /* Return a value of 0 as the log file number on failure. */
+ *valp = 0;
+--- 309,321 ----
+ int find_first, *valp;
+ logfile_validity *statusp;
+ {
+! logfile_validity logval_status, status;
+ u_int32_t clv, logval;
+ int cnt, fcnt, ret;
+ const char *dir;
+ char **names, *p, *q, savech;
+
+! logval_status = status = DB_LV_NONEXISTENT;
+
+ /* Return a value of 0 as the log file number on failure. */
+ *valp = 0;
+***************
+*** 385,394 ****
+ * as a valid log file.
+ */
+ break;
+ case DB_LV_NORMAL:
+ case DB_LV_OLD_READABLE:
+ logval = clv;
+! clv_status = status;
+ break;
+ case DB_LV_OLD_UNREADABLE:
+ /*
+--- 385,398 ----
+ * as a valid log file.
+ */
+ break;
++ case DB_LV_NONEXISTENT:
++ /* Should never happen. */
++ DB_ASSERT(0);
++ break;
+ case DB_LV_NORMAL:
+ case DB_LV_OLD_READABLE:
+ logval = clv;
+! logval_status = status;
+ break;
+ case DB_LV_OLD_UNREADABLE:
+ /*
+***************
+*** 410,416 ****
+ */
+ if (!find_first) {
+ logval = clv;
+! clv_status = status;
+ }
+ break;
+ }
+--- 414,420 ----
+ */
+ if (!find_first) {
+ logval = clv;
+! logval_status = status;
+ }
+ break;
+ }
+***************
+*** 420,426 ****
+
+ err: __os_dirfree(names, fcnt);
+ __os_freestr(p);
+! *statusp = clv_status;
+
+ return (ret);
+ }
+--- 424,430 ----
+
+ err: __os_dirfree(names, fcnt);
+ __os_freestr(p);
+! *statusp = logval_status;
+
+ return (ret);
+ }
diff --git a/sys-libs/db/files/patch.3.2.9.2 b/sys-libs/db/files/patch.3.2.9.2
new file mode 100644
index 000000000000..4092cda52eac
--- /dev/null
+++ b/sys-libs/db/files/patch.3.2.9.2
@@ -0,0 +1,21 @@
+*** log/log_rec.c.orig 2001/01/25 18:22:56 11.49
+--- log/log_rec.c 2001/02/07 22:17:46
+***************
+*** 404,410 ****
+ TAILQ_INIT(&logp->dbentry[i].dblist);
+ else
+ TAILQ_REINSERT_HEAD(
+! &logp->dbentry[i].dblist, dbp, links);
+ }
+
+ /* Initialize the new entries. */
+--- 404,410 ----
+ TAILQ_INIT(&logp->dbentry[i].dblist);
+ else
+ TAILQ_REINSERT_HEAD(
+! &logp->dbentry[i].dblist, dbtmp, links);
+ }
+
+ /* Initialize the new entries. */
+
+