summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-30 23:14:00 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-30 23:14:00 +0000
commit0cd87270290e80a3f25623eb64fe1102dbae6033 (patch)
tree03769626ea1ec391731db0af62706d3faae6b1c2 /sys-libs/ncurses/ncurses-5.2.ebuild
parentcute little gnome-vfs fix (diff)
downloadhistorical-0cd87270290e80a3f25623eb64fe1102dbae6033.tar.gz
historical-0cd87270290e80a3f25623eb64fe1102dbae6033.tar.bz2
historical-0cd87270290e80a3f25623eb64fe1102dbae6033.zip
Prepared for rc3
Diffstat (limited to 'sys-libs/ncurses/ncurses-5.2.ebuild')
-rw-r--r--sys-libs/ncurses/ncurses-5.2.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/sys-libs/ncurses/ncurses-5.2.ebuild b/sys-libs/ncurses/ncurses-5.2.ebuild
index b9763d65b639..0124bcf09089 100644
--- a/sys-libs/ncurses/ncurses-5.2.ebuild
+++ b/sys-libs/ncurses/ncurses-5.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.2.ebuild,v 1.2 2000/11/27 15:12:34 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.2.ebuild,v 1.3 2000/11/30 23:14:00 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,20 +9,19 @@ DESCRIPTION="Linux console display libarary"
SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/ncurses/${A}
ftp://ftp.gnu.org/pub/gnu/ncurses/${A}"
HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
+DEPEND=">=sys-libs/gpm-1.19.3"
src_compile() {
- try ./configure --prefix=/usr --enable-symlinks --disable-termcap \
- --with-gpm --with-shared --without-debug --with-rcs-ids --host=${CHOST}
- try make
+ try ./configure --prefix=/usr --libdir=/lib --enable-symlinks --disable-termcap \
+ --with-gpm --with-shared --with-libtool --without-debug --with-rcs-ids --host=${CHOST}
+ try make ${MAKEOPTS}
}
src_install() {
- try make prefix=${D}/usr install ticdir=${D}/usr/share/terminfo
- #move to root so that we can use ncurses on boot
- cd ${D}/usr/lib
- dodir /lib
- mv *.so* ../../lib
- preplib /
+ try make DESTDIR=${D} install
+ cd ${D}/lib
+ ln -s libncurses.a libcurses.a
+ chmod 755 ${D}/lib/*.5.0.2
cd ${S}
dodoc ANNOUNCE MANIFEST NEWS README* TO-DO
dodoc doc/*.doc
@@ -36,7 +35,6 @@ src_install() {
dodoc doc/html/ada/funcs/*.htm
docinto html/man
dodoc doc/html/man/*.html
- gzip ${D}/usr/man/man1/tack.1
}