summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2006-06-14 15:05:32 +0000
committerHanno Boeck <hanno@gentoo.org>2006-06-14 15:05:32 +0000
commite313d26479f7ead7ab5c16d5399f23c83890256e (patch)
tree8b8eaf371e5e3b9143791812b17833fcdc23d940 /sys-libs/libchipcard/libchipcard-2.1.4.ebuild
parentStable on amd64, bug 135660. Removed old version. (diff)
downloadhistorical-e313d26479f7ead7ab5c16d5399f23c83890256e.tar.gz
historical-e313d26479f7ead7ab5c16d5399f23c83890256e.tar.bz2
historical-e313d26479f7ead7ab5c16d5399f23c83890256e.zip
libchipcard bump
Package-Manager: portage-2.1
Diffstat (limited to 'sys-libs/libchipcard/libchipcard-2.1.4.ebuild')
-rw-r--r--sys-libs/libchipcard/libchipcard-2.1.4.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-libs/libchipcard/libchipcard-2.1.4.ebuild b/sys-libs/libchipcard/libchipcard-2.1.4.ebuild
new file mode 100644
index 000000000000..cecba764ea5a
--- /dev/null
+++ b/sys-libs/libchipcard/libchipcard-2.1.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libchipcard/libchipcard-2.1.4.ebuild,v 1.1 2006/06/14 15:05:32 hanno Exp $
+
+inherit eutils
+
+MY_P="${PN}2-${PV}"
+DESCRIPTION="Libchipcard is a library for easy access to chip cards via chip card readers (terminals)."
+HOMEPAGE="http://www.libchipcard.de"
+SRC_URI="mirror://sourceforge/libchipcard/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="debug doc ssl usb"
+
+DEPEND=">=sys-libs/gwenhywfar-2.2.0
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ usb? ( dev-libs/libusb )
+ >=sys-fs/sysfsutils-1.2.0"
+
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable usb libusb` \
+ --datadir=/usr/lib/chipcard2-server \
+ --localstatedir=/var \
+ --enable-pcsc || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # ctapi.h conflicts with towitoko-package
+ rm ${D}/usr/include/ctapi.h
+
+ doinitd ${FILESDIR}/chipcardd2
+ cp ${D}/etc/chipcard2-client/chipcardc2.conf.example \
+ ${D}/etc/chipcard2-client/chipcardc2.conf
+ cp ${D}/etc/chipcard2-server/chipcardd2.conf.minimal \
+ ${D}/etc/chipcard2-server/chipcardd2.conf
+
+ dodoc AUTHORS ChangeLog README doc/CERTIFICATES doc/CONFIG doc/IPCCOMMANDS
+ if use doc ; then
+ docinto tutorials
+ dodoc tutorials/*.{c,h,xml} tutorials/README
+ fi
+}