summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-04-17 15:31:51 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-04-17 15:31:51 +0000
commit493524dcb610cc8969a8f7bfedd3238f35836528 (patch)
treec40971ae479712d99327559e766936e2b484d89d /sys-kernel/xfs-sources/xfs-sources-2.4.24-r5.ebuild
parentAdded patches for the CAN-2004-0010, CAN-2004-0177 and CAN-2004-0178 vulnerab... (diff)
downloadhistorical-493524dcb610cc8969a8f7bfedd3238f35836528.tar.gz
historical-493524dcb610cc8969a8f7bfedd3238f35836528.tar.bz2
historical-493524dcb610cc8969a8f7bfedd3238f35836528.zip
Added patches for the CAN-2004-0010, CAN-2004-0177 and CAN-2004-0178 vulnerabilities.
Diffstat (limited to 'sys-kernel/xfs-sources/xfs-sources-2.4.24-r5.ebuild')
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.24-r5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.24-r5.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.24-r5.ebuild
new file mode 100644
index 000000000000..8c0d33606c9d
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.24-r5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.24-r5.ebuild,v 1.1 2004/04/17 15:31:51 plasmaroo Exp $
+
+ETYPE="sources"
+
+inherit kernel eutils
+IUSE=""
+OKV="`echo ${PV}|sed -e 's:^\([0-9]\+\.[0-9]\+\.[0-9]\+\).*:\1:'`"
+EXTRAVERSION="-${PN/-*/}-${PR}"
+KV=${OKV}${EXTRAVERSION}
+
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://dev.gentoo.org/~scox/kernels/v2.4/xfs-sources-${PV}-r3.patch.bz2"
+
+KEYWORDS="x86 -ppc -sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+ bzcat ${DISTDIR}/xfs-sources-${PV}-r3.patch.bz2 | patch -p1 \
+ || die "Failed to patch kernel"
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}.munmap.patch || die "Failed to apply munmap!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0010.patch || die "Failed to add the CAN-2004-0010 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0109.patch || die "Failed to patch CAN-2004-0109 vulnerability!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0177.patch || die "Failed to add the CAN-2004-0177 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0178.patch || die "Failed to add the CAN-2004-0178 patch!"
+
+ make mrproper || die "make mrproper failed"
+ kernel_universal_unpack
+}