summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-05-11 21:00:19 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-05-11 21:00:19 +0000
commitc09d87e9dd0b2a305b72a929513c46e5cb63bed7 (patch)
tree5fa6e44533151a4be18fa99d100311ea6f6f98b5 /sys-kernel/linux-docs/linux-docs-2.6.16.ebuild
parentAdded blocker on freealut to 20050504 versions of openal since they include a... (diff)
downloadhistorical-c09d87e9dd0b2a305b72a929513c46e5cb63bed7.tar.gz
historical-c09d87e9dd0b2a305b72a929513c46e5cb63bed7.tar.bz2
historical-c09d87e9dd0b2a305b72a929513c46e5cb63bed7.zip
Initial versions of split-out Linux kernel documentation (man pages, HTML docs). Will eventually fix bug #131648.
Package-Manager: portage-2203-svn
Diffstat (limited to 'sys-kernel/linux-docs/linux-docs-2.6.16.ebuild')
-rw-r--r--sys-kernel/linux-docs/linux-docs-2.6.16.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-2.6.16.ebuild b/sys-kernel/linux-docs/linux-docs-2.6.16.ebuild
new file mode 100644
index 000000000000..98dde1cb24f4
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-2.6.16.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-2.6.16.ebuild,v 1.1 2006/05/11 21:00:19 brix Exp $
+
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="mirror://kernel/pub/linux/kernel/v2.6/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="html"
+DEPEND="app-text/docbook-sgml-utils
+ app-text/xmlto
+ sys-apps/sed"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e "s:db2:docbook2:g" \
+ -e "s:/usr/local/man:${D}/usr/share/man:g" \
+ ${S}/Documentation/DocBook/Makefile
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make mandocs || die "make mandocs failed"
+
+ if use html; then
+ make htmldocs || die "make htmldocs failed"
+ fi
+}
+
+src_install() {
+ local file
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make installmandocs || die "make installmandocs failed"
+
+ if use html; then
+ for file in Documentation/DocBook/*.html; do
+ dohtml -r ${file/\.html/}
+ done
+ fi
+}