summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-21 10:58:40 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-21 10:58:40 +0000
commit67732ca1f16941862693373888bcf5dfee772b5a (patch)
tree846d32325f50bc38c075f17547afaa099675b2c2 /sys-kernel/hppa-dev-sources
parentmore error checking/messages (diff)
downloadhistorical-67732ca1f16941862693373888bcf5dfee772b5a.tar.gz
historical-67732ca1f16941862693373888bcf5dfee772b5a.tar.bz2
historical-67732ca1f16941862693373888bcf5dfee772b5a.zip
ver bump
Diffstat (limited to 'sys-kernel/hppa-dev-sources')
-rw-r--r--sys-kernel/hppa-dev-sources/ChangeLog7
-rw-r--r--sys-kernel/hppa-dev-sources/files/digest-hppa-dev-sources-2.6.1_p88
-rw-r--r--sys-kernel/hppa-dev-sources/hppa-dev-sources-2.6.1_p8.ebuild42
3 files changed, 56 insertions, 1 deletions
diff --git a/sys-kernel/hppa-dev-sources/ChangeLog b/sys-kernel/hppa-dev-sources/ChangeLog
index ce193662daba..e464c6a78bf3 100644
--- a/sys-kernel/hppa-dev-sources/ChangeLog
+++ b/sys-kernel/hppa-dev-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/hppa-dev-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hppa-dev-sources/ChangeLog,v 1.4 2004/01/15 05:25:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hppa-dev-sources/ChangeLog,v 1.5 2004/01/21 10:58:40 vapier Exp $
+
+*hppa-dev-sources-2.6.1_p8 (21 Jan 2004)
+
+ 21 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
*hppa-dev-sources-2.6.1_p2 (14 Jan 2004)
diff --git a/sys-kernel/hppa-dev-sources/files/digest-hppa-dev-sources-2.6.1_p8 b/sys-kernel/hppa-dev-sources/files/digest-hppa-dev-sources-2.6.1_p8
new file mode 100644
index 000000000000..8da7db0e678e
--- /dev/null
+++ b/sys-kernel/hppa-dev-sources/files/digest-hppa-dev-sources-2.6.1_p8
@@ -0,0 +1,8 @@
+MD5 fa82d1e4be518261b2eeb78eabf9cca7 linux-2.6.1.tar.bz2 33240033
+MD5 40bc115d94c4289deda874f2f6f5f6af patch-2.6.1-pa1.gz 116967
+MD5 80666434d715bfe05e15d12a740c2ed4 patch-2.6.1-pa1-pa2.gz 1877
+MD5 f7517c1f0bb356cecab7a8d06921e842 patch-2.6.1-pa2-pa3.gz 15149
+MD5 d61d4a6c86972c52dc8cb2c80bf62cd2 patch-2.6.1-pa3-pa4.gz 5331
+MD5 24b3ffc288f746d0062cb3af4f7f671b patch-2.6.1-pa4-pa5.gz 12492
+MD5 45b9855e80a260f6c663eb732a67bb5d patch-2.6.1-pa5-pa7.gz 9669
+MD5 9fd0648fc03401a3e8a7085cfb91559b patch-2.6.1-pa7-pa8.gz 2982
diff --git a/sys-kernel/hppa-dev-sources/hppa-dev-sources-2.6.1_p8.ebuild b/sys-kernel/hppa-dev-sources/hppa-dev-sources-2.6.1_p8.ebuild
new file mode 100644
index 000000000000..1d02ca9cb8cf
--- /dev/null
+++ b/sys-kernel/hppa-dev-sources/hppa-dev-sources-2.6.1_p8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hppa-dev-sources/hppa-dev-sources-2.6.1_p8.ebuild,v 1.1 2004/01/21 10:58:40 vapier Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+inherit kernel
+OKV="${PV/_p*/}"
+PATCH_LEVEL="${PV/${OKV}_p/}"
+KV=${OKV}-pa${PATCH_LEVEL}
+EXTRAVERSION="-pa${PATCH_LEVEL}"
+S=${WORKDIR}/linux-${KV}
+
+PATCH_SET="1 2 3 4 5 7 8"
+PATCH_COUNT="$(( `echo ${PATCH_SET} | wc -w` - 1 ))"
+
+DESCRIPTION="Full sources for the Linux kernel with patch for hppa"
+SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2 http://ftp.parisc-linux.org/cvs/linux-2.6/patch-${OKV}-pa`echo ${PATCH_SET} | awk '{ print $1 }'`.gz
+`for i in \`seq 1 ${PATCH_COUNT}\`; do echo http://ftp.parisc-linux.org/cvs/linux-2.6/patch-${OKV}-pa\`echo ${PATCH_SET} | awk \"{ print \\\\\$$i }\"\`-pa\`echo ${PATCH_SET} | awk \"{ print \\\\\$$((i + 1)) }\"\`.gz; done`"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://parisc-linux.org"
+KEYWORDS="hppa -*"
+SLOT="${KV}"
+
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv ${WORKDIR}/linux-${OKV} ${WORKDIR}/linux-${KV}
+ cd ${S}
+
+ einfo Applying ${OKV}-pa`echo ${PATCH_SET} | awk '{ print $1 }'`
+ zcat ${DISTDIR}/patch-${OKV}-pa`echo ${PATCH_SET} | awk '{ print $1 }'`.gz | patch -sp 1
+
+ for i in `seq 1 ${PATCH_COUNT}`
+ do
+ a=`echo ${PATCH_SET} | awk "{ print \\\$$i }"`
+ b=`echo ${PATCH_SET} | awk "{ print \\\$$((i + 1)) }"`
+ einfo Applying patch from ${OKV}-pa${a} to ${OKV}-pa${b}
+ zcat ${DISTDIR}/patch-${OKV}-pa${a}-pa${b}.gz | patch -sp 1
+ done
+
+ ARCH=parisc kernel_universal_unpack
+}