summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-04 07:30:40 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-04 07:30:40 +0000
commit7003626493c0e82aedb1103f583e938bd826ea15 (patch)
treecaf4d95348e310eb1173173291afe7c4109e834d /sys-fs
parentMoving to sys-fs/squashfs-tools (diff)
downloadhistorical-7003626493c0e82aedb1103f583e938bd826ea15.tar.gz
historical-7003626493c0e82aedb1103f583e938bd826ea15.tar.bz2
historical-7003626493c0e82aedb1103f583e938bd826ea15.zip
Moved from sys-apps/squashfs-tools to sys-fs/squashfs-tools.
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog23
-rw-r--r--sys-fs/squashfs-tools/Manifest4
-rw-r--r--sys-fs/squashfs-tools/files/digest-squashfs-tools-1.31
-rw-r--r--sys-fs/squashfs-tools/metadata.xml8
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild34
5 files changed, 70 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
new file mode 100644
index 000000000000..a6bc0dcf47d7
--- /dev/null
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -0,0 +1,23 @@
+# ChangeLog for sys-apps/squashfs-tools
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.1 2004/06/04 07:30:40 dragonheart Exp $
+
+ 04 Jun 2004; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +squashfs-tools-1.3.ebuild:
+ Moved from sys-apps/squashfs-tools to sys-fs/squashfs-tools.
+
+ 03 May 2004; Mike Frysinger <vapier@gentoo.org> :
+ Clean up ebuild and make it look nice.
+
+ 26 Apr 2004; Daniel Black <dragonheart@gentoo.org> metadata.xml:
+ Added embedded to the ownership. version 1.3 is realy 1.3_p3. Can the next
+ version include proper naming. Ref bug #47995
+
+ 15 Apr 2004; Michael McCabe <randy@gentoo.org> squashfs-tools-1.3.ebuild:
+ adding s390 to keywords
+
+*squashfs-tools-1.3 (14 Feb 2004)
+
+ 14 Feb 2004; Brad House <brad_mssw@gentoo.org> squashfs-tools-1.3.ebuild:
+ Initial commit
+
diff --git a/sys-fs/squashfs-tools/Manifest b/sys-fs/squashfs-tools/Manifest
new file mode 100644
index 000000000000..b402e7bdbc69
--- /dev/null
+++ b/sys-fs/squashfs-tools/Manifest
@@ -0,0 +1,4 @@
+MD5 fee0a11be0b39d332785d9a85127fb49 files/digest-squashfs-tools-1.3 64
+MD5 4a00eb3f27405e45696d2a0e2dd8fa03 ChangeLog 747
+MD5 e24fdae2cab763302d83ce65ce632106 squashfs-tools-1.3.ebuild 822
+MD5 c7abfbaf2964534151718bdccb79bce3 metadata.xml 228
diff --git a/sys-fs/squashfs-tools/files/digest-squashfs-tools-1.3 b/sys-fs/squashfs-tools/files/digest-squashfs-tools-1.3
new file mode 100644
index 000000000000..90f5aa6e11ca
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/digest-squashfs-tools-1.3
@@ -0,0 +1 @@
+MD5 650fd9a7b152bcfb7464276d3da296a9 squashfs1.3r3.tar.gz 89468
diff --git a/sys-fs/squashfs-tools/metadata.xml b/sys-fs/squashfs-tools/metadata.xml
new file mode 100644
index 000000000000..1eff8906aac8
--- /dev/null
+++ b/sys-fs/squashfs-tools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>embedded</herd>
+ <maintainer>
+ <email>embedded@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild b/sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild
new file mode 100644
index 000000000000..b0747b62271e
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild,v 1.1 2004/06/04 07:30:40 dragonheart Exp $
+
+MY_PV="1.3r3"
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha arm hppa amd64 ~ia64 ~ppc64 s390"
+IUSE=""
+
+DEPEND="virtual/glibc
+ sys-libs/zlib"
+
+S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin mksquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES
+}