summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-01-05 02:12:21 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-01-05 02:12:21 +0000
commit249cfc38889579cc8397c9a2cff31d3bcdedc407 (patch)
tree78fba205ee742b92e75c70c0946147102eb83868 /sys-fs
parentmetadata updates -> maintainer-needed (diff)
downloadhistorical-249cfc38889579cc8397c9a2cff31d3bcdedc407.tar.gz
historical-249cfc38889579cc8397c9a2cff31d3bcdedc407.tar.bz2
historical-249cfc38889579cc8397c9a2cff31d3bcdedc407.zip
version bump
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/captive/ChangeLog12
-rw-r--r--sys-fs/captive/Manifest4
-rw-r--r--sys-fs/captive/captive-1.1.7.ebuild85
-rw-r--r--sys-fs/captive/files/digest-captive-1.1.71
4 files changed, 99 insertions, 3 deletions
diff --git a/sys-fs/captive/ChangeLog b/sys-fs/captive/ChangeLog
index afaee8c54c39..24d08d752c6a 100644
--- a/sys-fs/captive/ChangeLog
+++ b/sys-fs/captive/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/captive
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/ChangeLog,v 1.9 2005/12/29 18:18:28 genstef Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/ChangeLog,v 1.10 2006/01/05 02:12:21 genstef Exp $
+
+ 05 Jan 2006; Stefan Schweizer <genstef@gentoo.org> +captive-1.1.7.ebuild:
+ version bump
+
+*captive-1.1.7 (05 Jan 2006)
+
+ 05 Jan 2006; Stefan Schweizer <genstef@gentoo.org> +captive-1.1.7.ebuild:
+ version bump
29 Dec 2005; Stefan Schweizer <genstef@gentoo.org> ChangeLog:
version bump
diff --git a/sys-fs/captive/Manifest b/sys-fs/captive/Manifest
index 4e8ac7c02035..d9809e6f9ea2 100644
--- a/sys-fs/captive/Manifest
+++ b/sys-fs/captive/Manifest
@@ -1,9 +1,11 @@
-MD5 88fc438f1c6539e62191a334297a0a35 ChangeLog 2392
+MD5 47c59ee0b52531e78a2e6f1812e5554b ChangeLog 2607
MD5 e713979a7c0acc2e3f22f790a59bd5eb captive-1.1.5-r2.ebuild 2806
MD5 631d8380563a00bc2af58eba86d02d56 captive-1.1.6.ebuild 2186
+MD5 557a7d627388a1e74298937775f530c0 captive-1.1.7.ebuild 2118
MD5 09de72e8ea997c51e2cdd999343d63ac files/add-extra-opts-for-user-access-to-mount-t-captive.patch 647
MD5 00da6b972db84ffd52c945b07c3204d4 files/digest-captive-1.1.5-r2 148
MD5 08d428f29220c44d67ab40deb8eca20d files/digest-captive-1.1.6 69
+MD5 97c4866013f93fd3e57565626e0697b2 files/digest-captive-1.1.7 69
MD5 af3ab379ab00c1a99eaaa24e67007377 files/do-not-check-for-lufsd.patch 1090
MD5 ec2f404ce7a254d2d75101c257fdd9ce files/use-lufis-for-mount-t-captive.patch 1041
MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
diff --git a/sys-fs/captive/captive-1.1.7.ebuild b/sys-fs/captive/captive-1.1.7.ebuild
new file mode 100644
index 000000000000..529953fadc95
--- /dev/null
+++ b/sys-fs/captive/captive-1.1.7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/captive-1.1.7.ebuild,v 1.1 2006/01/05 02:12:21 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="Captive uses binary Windows drivers for full NTFS r/w access."
+HOMEPAGE="http://www.jankratochvil.net/project/captive/"
+SRC_URI="http://www.jankratochvil.net/priv/captive/${P}cvs.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -*"
+
+IUSE="debug gtk readline"
+
+RDEPEND="sys-libs/zlib
+ >=sys-fs/fuse-2.4
+ sys-fs/ntfsprogs
+ readline? ( sys-libs/readline )
+ >=dev-libs/openssl-0.9.7c
+ >=dev-libs/libxml2-2.4.29
+ >=gnome-base/orbit-2.8.2
+ gnome-base/gconf
+ gnome-base/libbonobo
+ gnome-base/gnome-vfs
+ dev-libs/popt
+ dev-libs/glib
+ gtk? ( dev-libs/atk
+ gnome-base/libbonoboui
+ gnome-base/libgnomeui
+ media-libs/libpng
+ >x11-libs/gtk+-2.2
+ x11-libs/pango )"
+
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}cvs
+
+pkg_setup() {
+ einfo "Adding captive user and group"
+ enewgroup captive || die "enewgroup captive failed"
+ enewuser captive -1 -1 /dev/null captive || die "enewuser captive failed"
+}
+
+src_compile() {
+ # disable some tests to save time ;)
+ econf $(use_enable debug bug-replay) \
+ $(use_with readline) \
+ $(use_enable gtk install-pkg) \
+ --enable-fuse \
+ --disable-glibtest --disable-orbittest \
+ --with-tmpdir=/tmp --localstatedir=/var || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodir /var/lib/captive
+ diropts -m1777
+ dodir /var/lib/captive/tmp
+ keepdir /var/lib/captive/tmp
+
+ rm -R ${D}/etc/rc.d
+
+ dodoc AUTHORS ChangeLog README TODO
+}
+
+pkg_postinst() {
+ einfo "Use /usr/sbin/captive-install-acquire to search for and"
+ einfo "install the needed drivers for captive NTFS."
+ einfo ""
+ einfo "Please use \"mount -t captive-ntfs /dev/hda1 /mnt/ntfs\" to mount ntfs partitions."
+}
+
+pkg_postrm() {
+ #einfo Removing captive user
+ #userdel captive
+ #einfo Removing captive group
+ #groupdel captive
+ einfo ""
+ einfo "You will have to remove captive user and group manually"
+ einfo ""
+}
diff --git a/sys-fs/captive/files/digest-captive-1.1.7 b/sys-fs/captive/files/digest-captive-1.1.7
new file mode 100644
index 000000000000..94a2712a675a
--- /dev/null
+++ b/sys-fs/captive/files/digest-captive-1.1.7
@@ -0,0 +1 @@
+MD5 8617684bf2b987b623cfa45b940bfbfc captive-1.1.7cvs.tar.gz 2892804