summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-04 02:50:59 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-04 02:50:59 +0000
commitfc78ead51b510cb2f20d3aa37740098bc17230c1 (patch)
tree4e94e304d60657298650456a64616b6a16103f7f /sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
parentkeyword ~amd64-linux ~x86-linux (diff)
downloadhistorical-fc78ead51b510cb2f20d3aa37740098bc17230c1.tar.gz
historical-fc78ead51b510cb2f20d3aa37740098bc17230c1.tar.bz2
historical-fc78ead51b510cb2f20d3aa37740098bc17230c1.zip
Add another snapshot. Remove the ewarn messages from pkg_postinst; hopefully people have upgraded their kernels by now.
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'sys-fs/btrfs-progs/btrfs-progs-9999.ebuild')
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-9999.ebuild38
1 files changed, 22 insertions, 16 deletions
diff --git a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
index b1bfa07f45fd..4ec82f0a4178 100644
--- a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
+++ b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
@@ -1,18 +1,25 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild,v 1.21 2012/10/11 08:06:57 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild,v 1.22 2013/02/04 02:50:57 floppym Exp $
EAPI=4
-inherit git-2 toolchain-funcs
+inherit toolchain-funcs
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="http://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+else
+ inherit git-2
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs.git
+ https://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs.git"
+fi
DESCRIPTION="Btrfs filesystem utilities"
HOMEPAGE="https://btrfs.wiki.kernel.org"
-SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE=""
DEPEND="sys-libs/zlib
@@ -20,19 +27,18 @@ DEPEND="sys-libs/zlib
sys-fs/e2fsprogs"
RDEPEND="${DEPEND}"
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs.git
- https://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs.git"
-
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake \
+ CC="$(tc-getCC)" \
+ AM_CFLAGS=-D_FILE_OFFSET_BITS=64 \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
}
src_install() {
- emake DESTDIR="${D}" prefix=/usr bindir=/sbin mandir=/usr/share/man install
-}
-
-pkg_postinst() {
- ewarn "WARNING: This version of btrfs-progs uses the latest unstable code,"
- ewarn " and care should be taken that it is compatible with the"
- ewarn " version of btrfs in your kernel!"
+ emake install \
+ DESTDIR="${D}" \
+ prefix=/usr \
+ bindir=/sbin \
+ mandir=/usr/share/man
}