summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2012-04-09 02:20:07 +0000
committerJoe Peterson <lavajoe@gentoo.org>2012-04-09 02:20:07 +0000
commitbbcfe4a35136a1c7b8733ad15567bd4e216e45c8 (patch)
tree76cc6e3692ec366b8fe3f47828770dbb45a78cf5 /sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
parentDrop old epunt_cxx calls #410877 by Greg Turner. (diff)
downloadhistorical-bbcfe4a35136a1c7b8733ad15567bd4e216e45c8.tar.gz
historical-bbcfe4a35136a1c7b8733ad15567bd4e216e45c8.tar.bz2
historical-bbcfe4a35136a1c7b8733ad15567bd4e216e45c8.zip
Rewrite live ebuild to take advantage of improved upstream Makefiles (bug #411209) and fix bug #410765 - thanks go to floppym@gentoo.org for new ebuild
Package-Manager: portage-2.1.10.47/cvs/Linux x86_64
Diffstat (limited to 'sys-fs/btrfs-progs/btrfs-progs-9999.ebuild')
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-9999.ebuild69
1 files changed, 12 insertions, 57 deletions
diff --git a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
index c9cc70c40ee2..edd3849fc8d3 100644
--- a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
+++ b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild,v 1.16 2012/02/10 21:45:37 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild,v 1.17 2012/04/09 02:20:07 lavajoe Exp $
-inherit eutils git-2
+EAPI=4
+
+inherit eutils git-2 toolchain-funcs
DESCRIPTION="Btrfs filesystem utilities"
HOMEPAGE="http://btrfs.wiki.kernel.org/"
@@ -11,74 +13,27 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="acl debug-utils"
+IUSE=""
DEPEND="sys-libs/zlib
- debug-utils? ( dev-python/matplotlib )
- acl? (
- sys-apps/acl
- sys-fs/e2fsprogs
- )"
+ sys-apps/acl
+ sys-fs/e2fsprogs"
RDEPEND="${DEPEND}"
EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs.git"
-src_unpack() {
- git-2_src_unpack
- cd "${S}"
-
+src_prepare() {
# Fix hardcoded "gcc" and "make"
- sed -i -e 's:gcc $(CFLAGS):$(CC) $(CFLAGS):' Makefile
- sed -i -e 's:make:$(MAKE):' Makefile
+ sed -i -e 's:gcc $(CFLAGS):$(CC) $(CFLAGS):' Makefile || die
+ sed -i -e 's:make:$(MAKE):' Makefile || die
}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- all || die
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- btrfstune btrfs-image || die
- if use acl; then
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- convert || die
- fi
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {
- into /
- dosbin btrfs-show
- dosbin btrfs-vol
- dosbin btrfsctl
- dosbin btrfsck
- dosbin btrfstune
- dosbin btrfs-image
- dosbin btrfs
- # fsck will segfault if invoked at boot, so do not make this link
- #dosym btrfsck /sbin/fsck.btrfs
- newsbin mkfs.btrfs mkbtrfs
- dosym mkbtrfs /sbin/mkfs.btrfs
- if use acl; then
- dosbin btrfs-convert
- else
- ewarn "Note: btrfs-convert not built/installed (requires acl USE flag)"
- fi
-
- if use debug-utils; then
- dobin btrfs-debug-tree
- else
- ewarn "Note: btrfs-debug-tree not installed (requires debug-utils USE flag)"
- fi
-
- into /usr
- newbin bcp btrfs-bcp
-
- if use debug-utils; then
- newbin show-blocks btrfs-show-blocks
- else
- ewarn "Note: btrfs-show-blocks not installed (requires debug-utils USE flag)"
- fi
-
- dodoc INSTALL
- emake prefix="${D}/usr/share" install-man
+ emake DESTDIR="${D}" prefix=/usr bindir=/sbin mandir=/usr/share/man install
}
pkg_postinst() {