summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-05-22 11:14:47 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-05-22 11:14:47 +0000
commitfda677117c5a29f8c76eec208441f98ec5ae8abb (patch)
treee332e7ac673e428d6f85055e0eff1833f647461f /sys-freebsd/boot0
parentVersion bump. Cleanup (diff)
downloadhistorical-fda677117c5a29f8c76eec208441f98ec5ae8abb.tar.gz
historical-fda677117c5a29f8c76eec208441f98ec5ae8abb.tar.bz2
historical-fda677117c5a29f8c76eec208441f98ec5ae8abb.zip
bump to 7.2
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'sys-freebsd/boot0')
-rw-r--r--sys-freebsd/boot0/ChangeLog7
-rw-r--r--sys-freebsd/boot0/boot0-7.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-freebsd/boot0/ChangeLog b/sys-freebsd/boot0/ChangeLog
index 96b6a47809f4..20edfcad185a 100644
--- a/sys-freebsd/boot0/ChangeLog
+++ b/sys-freebsd/boot0/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-freebsd/boot0
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.22 2009/01/22 20:59:52 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.23 2009/05/22 11:08:14 aballier Exp $
+
+*boot0-7.2 (22 May 2009)
+
+ 22 May 2009; Alexis Ballier <aballier@gentoo.org> +boot0-7.2.ebuild:
+ bump to 7.2
*boot0-7.1 (22 Jan 2009)
diff --git a/sys-freebsd/boot0/boot0-7.2.ebuild b/sys-freebsd/boot0/boot0-7.2.ebuild
new file mode 100644
index 000000000000..431726a52804
--- /dev/null
+++ b/sys-freebsd/boot0/boot0-7.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-7.2.ebuild,v 1.1 2009/05/22 11:08:14 aballier Exp $
+
+inherit bsdmk freebsd
+
+DESCRIPTION="FreeBSD's bootloader"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+
+IUSE=""
+
+SRC_URI="mirror://gentoo/${SYS}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
+ =sys-freebsd/freebsd-lib-${RV}*"
+
+S="${WORKDIR}/sys/boot"
+
+PATCHES=( "${FILESDIR}/boot0-7.0-gentoo.patch" )
+
+src_unpack() {
+ freebsd_src_unpack
+
+ grep -lr --null -- -ffreestanding "${S}" | xargs -0 sed -i -e \
+ "s:-ffreestanding:-ffreestanding $(test-flags -fno-stack-protector -fno-stack-protector-all):g" || die
+ sed -e '/-fomit-frame-pointer/d' -e '/-mno-align-long-strings/d' \
+ -i "${S}"/i386/boot2/Makefile \
+ -i "${S}"/i386/gptboot/Makefile || die
+}
+
+src_install() {
+ dodir /boot/defaults
+
+ mkinstall FILESDIR=/boot || die "mkinstall failed"
+}