summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-06-09 20:37:07 +0000
committerMike Frysinger <vapier@gentoo.org>2010-06-09 20:37:07 +0000
commited5066b8cf4b7c99557d10bf104d560e837b8cbb (patch)
treec315d2682445e7f6d220f559d240b43c60dbbd7e /sys-devel/libtool/libtool-2.2.10.ebuild
parentAdded revised ebuilds from my overlay, solving bug #236264 (they contain ruby... (diff)
downloadhistorical-ed5066b8cf4b7c99557d10bf104d560e837b8cbb.tar.gz
historical-ed5066b8cf4b7c99557d10bf104d560e837b8cbb.tar.bz2
historical-ed5066b8cf4b7c99557d10bf104d560e837b8cbb.zip
Version bump.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/libtool/libtool-2.2.10.ebuild')
-rw-r--r--sys-devel/libtool/libtool-2.2.10.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-devel/libtool/libtool-2.2.10.ebuild b/sys-devel/libtool/libtool-2.2.10.ebuild
new file mode 100644
index 000000000000..42bcedae4a13
--- /dev/null
+++ b/sys-devel/libtool/libtool-2.2.10.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.10.ebuild,v 1.1 2010/06/09 20:37:07 vapier Exp $
+
+EAPI="3"
+
+LIBTOOLIZE="true" #225559
+inherit eutils autotools multilib
+
+DESCRIPTION="A shared library tool for developers"
+HOMEPAGE="http://www.gnu.org/software/libtool/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="vanilla"
+
+RDEPEND="sys-devel/gnuconfig
+ >=sys-devel/autoconf-2.60
+ >=sys-devel/automake-1.10.1
+ !=sys-devel/libtool-2*:1.5"
+DEPEND="${RDEPEND}
+ >=sys-devel/binutils-2.20
+ || ( app-arch/xz-utils app-arch/lzma-utils )"
+
+src_prepare() {
+ if ! use vanilla ; then
+ epunt_cxx
+ cd libltdl/m4
+ epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
+ cd ..
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ cd ..
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ fi
+}
+
+src_configure() {
+ # the libtool script uses bash code in it and at configure time, tries
+ # to find a bash shell. if /bin/sh is bash, it uses that. this can
+ # cause problems for people who switch /bin/sh on the fly to other
+ # shells, so just force libtool to use /bin/bash all the time.
+ export CONFIG_SHELL=/bin/bash
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
+
+ for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
+ rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
+ done
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
+}