summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-19 17:40:01 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-19 17:40:01 +0000
commitfe28dc98294164bcc46b1224d135d971bd8dc75b (patch)
treeb91499c9f64e5658c003acb78b82b5e47cd52ad0 /sys-devel/gnuconfig
parentold (diff)
downloadhistorical-fe28dc98294164bcc46b1224d135d971bd8dc75b.tar.gz
historical-fe28dc98294164bcc46b1224d135d971bd8dc75b.tar.bz2
historical-fe28dc98294164bcc46b1224d135d971bd8dc75b.zip
Version bump.
Package-Manager: portage-2.2.0_alpha23/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/gnuconfig')
-rw-r--r--sys-devel/gnuconfig/ChangeLog7
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20110202.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index a047dabbfc2b..4f4231253598 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.53 2011/02/06 11:35:41 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.54 2011/02/19 17:40:01 vapier Exp $
+
+*gnuconfig-20110202 (19 Feb 2011)
+
+ 19 Feb 2011; Mike Frysinger <vapier@gentoo.org> +gnuconfig-20110202.ebuild:
+ Version bump.
06 Feb 2011; Mart Raudsepp <leio@gentoo.org> gnuconfig-20100403.ebuild,
gnuconfig-20100924.ebuild:
diff --git a/sys-devel/gnuconfig/gnuconfig-20110202.ebuild b/sys-devel/gnuconfig/gnuconfig-20110202.ebuild
new file mode 100644
index 000000000000..f46a735abaef
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20110202.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20110202.ebuild,v 1.1 2011/02/19 17:40:01 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/config.git"
+ inherit git
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="http://savannah.gnu.org/projects/config"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ cd "${S}"
+
+ local ver=$(head -n 1 ChangeLog | awk '{print $1}' | sed -e 's:-::g')
+ [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
+
+ cp "${FILESDIR}"/${PV}/*.patch . || die
+
+ local tar="${T}/gnuconfig-${ver}.tar.bz2"
+ tar -jcf ${tar} . || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b ${tar})"
+}
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git_src_unpack
+ maint_pkg_create
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/*.patch
+ use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
+}
+
+src_compile() { :;}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}