summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-25 22:28:00 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-25 22:28:00 +0000
commit2c2991de7ace6baae03b34882be3bc519f17327b (patch)
treeb675552b542cd058040add58b5117cc593031d4c /sys-devel/gdb/gdb-7.4.ebuild
parentapp-crypt/pkcrack: EAPI bump. Fix dependency on app-arch/zip to be app-arch/z... (diff)
downloadhistorical-2c2991de7ace6baae03b34882be3bc519f17327b.tar.gz
historical-2c2991de7ace6baae03b34882be3bc519f17327b.tar.bz2
historical-2c2991de7ace6baae03b34882be3bc519f17327b.zip
Set includedir to /usr/$CTARGET for cross-compilers #400729 by Karsten Steingaß.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/gdb/gdb-7.4.ebuild')
-rw-r--r--sys-devel/gdb/gdb-7.4.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-7.4.ebuild b/sys-devel/gdb/gdb-7.4.ebuild
index eb7bbe56c3cb..cbb5938f0a4b 100644
--- a/sys-devel/gdb/gdb-7.4.ebuild
+++ b/sys-devel/gdb/gdb-7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.4.ebuild,v 1.2 2012/01/25 19:31:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.4.ebuild,v 1.3 2012/01/25 22:28:00 vapier Exp $
EAPI="3"
@@ -86,11 +86,14 @@ gdb_branding() {
src_configure() {
strip-unsupported-flags
+ local sysroot="${EPREFIX}"/usr/${CTARGET}
local myconf=(
--with-pkgversion="$(gdb_branding)"
--with-bugurl='http://bugs.gentoo.org/'
--disable-werror
- $(is_cross && echo --with-sysroot="${EPREFIX}"/usr/${CTARGET})
+ $(is_cross && echo \
+ --with-sysroot="${sysroot}" \
+ --includedir="${sysroot}/usr/include")
)
if use server && ! use client ; then