summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-18 19:52:05 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-18 19:52:05 +0000
commit98195293f8934fb1f6ecb798ee855b3aa93df498 (patch)
tree94c8071aacdad3312a7dfb72b96f0938167dd9d0 /sys-devel/crossdev/crossdev-20140118.ebuild
parentStable for alpha, wrt bug #486370 (diff)
downloadhistorical-98195293f8934fb1f6ecb798ee855b3aa93df498.tar.gz
historical-98195293f8934fb1f6ecb798ee855b3aa93df498.tar.bz2
historical-98195293f8934fb1f6ecb798ee855b3aa93df498.zip
Version bump.
Package-Manager: portage-2.2.8/cvs/Linux x86_64 Manifest-Sign-Key: 0xD2E96200
Diffstat (limited to 'sys-devel/crossdev/crossdev-20140118.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20140118.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20140118.ebuild b/sys-devel/crossdev/crossdev-20140118.ebuild
new file mode 100644
index 000000000000..0d991cd1ccc3
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20140118.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20140118.ebuild,v 1.1 2014/01/18 19:52:02 vapier Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}