summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-05 10:26:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-05 10:26:55 +0000
commit46111927410fb3ee114735ececf0236204075a53 (patch)
tree7c1b00b2d1dedc2df5a42fd2517e0ba59b1504d2 /sys-devel/bmake/files
parentVersion bump (diff)
downloadhistorical-46111927410fb3ee114735ececf0236204075a53.tar.gz
historical-46111927410fb3ee114735ececf0236204075a53.tar.bz2
historical-46111927410fb3ee114735ececf0236204075a53.zip
version bump, dont run tests by default, add a src_test, install mk files in /usr/share/mk/P to avoid collisions.
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.3 x86_64
Diffstat (limited to 'sys-devel/bmake/files')
-rw-r--r--sys-devel/bmake/files/bmake-20080515-makefile.patch27
-rw-r--r--sys-devel/bmake/files/bmake-tests.patch22
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-devel/bmake/files/bmake-20080515-makefile.patch b/sys-devel/bmake/files/bmake-20080515-makefile.patch
new file mode 100644
index 000000000000..19c2ab71e9fc
--- /dev/null
+++ b/sys-devel/bmake/files/bmake-20080515-makefile.patch
@@ -0,0 +1,27 @@
+--- makefile.boot.in.old 2006-10-07 12:49:12.000000000 +0200
++++ makefile.boot.in 2006-10-07 13:42:22.000000000 +0200
+@@ -6,6 +6,7 @@
+ #
+ prefix=@prefix@
+ srcdir=@srcdir@
++mandir=@mandir@
+ VPATH=.:$(srcdir)
+ CC=@CC@
+ INSTALL=$(srcdir)/install-sh
+@@ -48,12 +49,12 @@
+ install: install-bin install-man install-mk
+
+ install-bin:
+- test -d ${prefix}/bin || ${INSTALL} -m 755 -d ${prefix}/bin
+- ${INSTALL} -m 755 bmake ${prefix}/bin
++ test -d ${DESTDIR}${prefix}/bin || ${INSTALL} -m 755 -d ${DESTDIR}${prefix}/bin
++ ${INSTALL} -m 755 ${srcdir}/bmake ${DESTDIR}${prefix}/bin
+
+ install-man:
+- test -d ${prefix}/man/cat1 || ${INSTALL} -m 755 -d ${prefix}/man/cat1
+- ${INSTALL} -m 444 ${srcdir}/bmake.cat1 ${prefix}/man/cat1/bmake.1
++ test -d ${DESTDIR}${mandir}/man1 || ${INSTALL} -m 755 -d ${DESTDIR}${mandir}/man1
++ ${INSTALL} -m 444 ${srcdir}/bmake.cat1 ${DESTDIR}${mandir}/man1/bmake.1
+
+ install-mk:
+ @if test -s ${MKSRC}/install-mk; then \
diff --git a/sys-devel/bmake/files/bmake-tests.patch b/sys-devel/bmake/files/bmake-tests.patch
new file mode 100644
index 000000000000..4c6ffe691da3
--- /dev/null
+++ b/sys-devel/bmake/files/bmake-tests.patch
@@ -0,0 +1,22 @@
+Index: bmake/makefile.boot.in
+===================================================================
+--- bmake.orig/makefile.boot.in
++++ bmake/makefile.boot.in
+@@ -31,13 +31,15 @@ BMAKE_ENV= CC="$(CC)" LIBC= MAKEFLAGS= M
+ bootstrap: bmake.boot .mk.done
+ ${BMAKE_ENV} ./bmake.boot -f Makefile
+ ${BMAKE_ENV} ./bmake.boot -f Makefile bmake.1
+- ${BMAKE_ENV} `pwd`/bmake -f Makefile test
+-
++
+ bmake: bmake.boot
+ @echo you might want to try:
+ @echo ${MAKE} -f makefile.boot bootstrap
+ cp bmake.boot $@
+
++check:
++ ${BMAKE_ENV} `pwd`/bmake -f Makefile test
++
+ bmake.boot: ${OBJ}
+ (cd lst.lib; $(MAKE) -f makefile.boot CC="$(CC)" CFLAGS="-I.. -I../${srcdir} -I${srcdir} ${CFLAGS}" )
+ ${CC} *.o lst.lib/*.o -o $@ @LDFLAGS@ @LIBS@