summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-10 02:37:32 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-10 02:37:32 +0000
commitcca03f2ce12aeed62565c51a0d2df0c930af24cc (patch)
treedef9af567bdb309706dfad5da7e6bcabee6d92d7 /sys-cluster
parentDEPEND on net-misc/netkit-fingerd, closes #59612 (diff)
downloadhistorical-cca03f2ce12aeed62565c51a0d2df0c930af24cc.tar.gz
historical-cca03f2ce12aeed62565c51a0d2df0c930af24cc.tar.bz2
historical-cca03f2ce12aeed62565c51a0d2df0c930af24cc.zip
clean up one ugly-ass ebuild
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/feedbackd-agent/Manifest14
-rw-r--r--sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild36
2 files changed, 27 insertions, 23 deletions
diff --git a/sys-cluster/feedbackd-agent/Manifest b/sys-cluster/feedbackd-agent/Manifest
index 6cd7bd07eca5..f425a861ea12 100644
--- a/sys-cluster/feedbackd-agent/Manifest
+++ b/sys-cluster/feedbackd-agent/Manifest
@@ -1,4 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 62673153bef61749f9759e2c5055a786 ChangeLog 538
-MD5 2532a10ecafb4e93fe9cad6381b5d0ac feedbackd-agent-0.3.1.ebuild 1305
-MD5 7ca761c8ea4dcc887a66cdb55cdde95d files/digest-feedbackd-agent-0.3.1 73
+MD5 6ee213be970ffec080d9177af452c19c feedbackd-agent-0.3.1.ebuild 972
MD5 560fedeed92761d71d6662879450213e files/compile-gnu-source.patch 346
+MD5 7ca761c8ea4dcc887a66cdb55cdde95d files/digest-feedbackd-agent-0.3.1 73
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.8 (GNU/Linux)
+
+iD8DBQFBGDUeHTu7gpaalycRAhxDAKDTmy808AGOsnMWNzjZWdLKL9ZkFACgmZtZ
+LFq5KzCc9mdAHtUI9K966HM=
+=m8XA
+-----END PGP SIGNATURE-----
diff --git a/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild b/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild
index cfc58b9d7992..276515e5d7c1 100644
--- a/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild
+++ b/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild
@@ -1,46 +1,40 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild,v 1.4 2004/07/15 02:53:37 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild,v 1.5 2004/08/10 02:37:32 vapier Exp $
-inherit eutils
-
-DESCRIPTION="Feedbackd is a client/server system that provides dynamic feedback of server
-load in a Linux Virtual Server (LVS)-based cluster. Monitor plugins are used to
-measure the health of each server, allowing a flexible way to report load back
-to the load balancer. It also facilitates the addition and removal of servers
-from the cluster.
-
-This is the agent process for feedbackd, which is run on the real server."
+inherit eutils flag-o-matic
+DESCRIPTION="system for dynamic feedback of server loads in a Linux Virtual Server (LVS)-based cluster"
HOMEPAGE="http://www.redfishsoftware.com.au/projects/feedbackd/"
-LICENSE="GPL-2"
-DEPEND="virtual/libc
- >=dev-libs/libxml2
- >=dev-lang/perl"
-
-SRC_URI="http://aleron.dl.sourceforge.net/sourceforge/feedbackd/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/feedbackd/${P}.tar.gz"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-src_compile() {
+DEPEND="virtual/libc
+ >=dev-libs/libxml2
+ >=dev-lang/perl"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/compile-gnu-source.patch
+ append-flags -O2
+}
- CFLAGS="${CFLAGS/-O?/} -O2" \
+src_compile() {
econf \
--sysconfdir=/etc \
--localstatedir=/var \
--with-xml-config=/usr/bin/xml2-config \
--with-perl=/usr/bin/perl \
|| die "bad ./configure"
-
- cd "${S}"
make || die
}
src_install() {
einstall || die
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
}