summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-03-10 18:49:06 +0000
committerAron Griffis <agriffis@gentoo.org>2006-03-10 18:49:06 +0000
commit0a99ba74536034ca89a9a23ade99a33eaf3e8dca (patch)
treeab3c2407d649fcd7564c40d992aab6eb8586dcab /sys-boot/elilo/elilo-3.6.ebuild
parentfix typo, bug#125709, thanks Martin Mokrejs (diff)
downloadhistorical-0a99ba74536034ca89a9a23ade99a33eaf3e8dca.tar.gz
historical-0a99ba74536034ca89a9a23ade99a33eaf3e8dca.tar.bz2
historical-0a99ba74536034ca89a9a23ade99a33eaf3e8dca.zip
Add elilo-3.4.gz to SRC_URI to fix script installation
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'sys-boot/elilo/elilo-3.6.ebuild')
-rw-r--r--sys-boot/elilo/elilo-3.6.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sys-boot/elilo/elilo-3.6.ebuild b/sys-boot/elilo/elilo-3.6.ebuild
index 1ba0a828adf9..913b6541af0e 100644
--- a/sys-boot/elilo/elilo-3.6.ebuild
+++ b/sys-boot/elilo/elilo-3.6.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.6.ebuild,v 1.3 2006/02/23 01:15:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.6.ebuild,v 1.4 2006/03/10 18:49:06 agriffis Exp $
inherit eutils toolchain-funcs
DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
HOMEPAGE="http://elilo.sourceforge.net/"
-SRC_URI="mirror://sourceforge/elilo/${P}.src.tgz"
+SRC_URI="mirror://sourceforge/elilo/${P}.src.tgz
+ mirror://gentoo/elilo-3.4.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -22,11 +23,11 @@ PROVIDE="virtual/bootloader"
S=${WORKDIR}/${PN}
src_unpack() {
- unpack ${A}
+ unpack ${P}.src.tgz
+ gzip -dc ${DISTDIR}/elilo-3.4.gz > elilo-script
cd ${S}
epatch ${FILESDIR}/elilo-3.4-makefile.patch
epatch ${FILESDIR}/elilo-3.3a-devscheme.patch
- gzip -dc ${DISTDIR}/elilo-3.4.gz > $T/elilo
}
src_compile() {
@@ -44,7 +45,7 @@ src_compile() {
}
src_install() {
- dosbin ${T}/elilo || die "elilo failed"
+ newsbin ${WORKDIR}/elilo-script elilo || die "elilo failed"
dosbin tools/eliloalt || die "eliloalt failed"
exeinto /usr/lib/elilo