summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-08-24 03:47:47 +0000
committerSven Wegener <swegener@gentoo.org>2004-08-24 03:47:47 +0000
commitbc840c07ff357e59645171d7654ecd3b2125b33f (patch)
treef3340c5a9d6c44bf32471955cea101eb968dc428 /sys-apps
parentMarking stable on x86 & clean up (diff)
downloadhistorical-bc840c07ff357e59645171d7654ecd3b2125b33f.tar.gz
historical-bc840c07ff357e59645171d7654ecd3b2125b33f.tar.bz2
historical-bc840c07ff357e59645171d7654ecd3b2125b33f.zip
use epatch for patching
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/tic98/ChangeLog6
-rw-r--r--sys-apps/tic98/tic98-1.01-r1.ebuild8
-rw-r--r--sys-apps/tic98/tic98-1.01.ebuild8
3 files changed, 15 insertions, 7 deletions
diff --git a/sys-apps/tic98/ChangeLog b/sys-apps/tic98/ChangeLog
index 1e7f637b470d..44b4f97e4ded 100644
--- a/sys-apps/tic98/ChangeLog
+++ b/sys-apps/tic98/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/tic98
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/ChangeLog,v 1.4 2004/06/24 22:29:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/ChangeLog,v 1.5 2004/08/24 03:47:47 swegener Exp $
+
+ 24 Aug 2004; Sven Wegener <swegener@gentoo.org> tic98-1.01-r1.ebuild,
+ tic98-1.01.ebuild:
+ use epatch for patching
*tic98-1.01-r1 (19 Oct 2003)
diff --git a/sys-apps/tic98/tic98-1.01-r1.ebuild b/sys-apps/tic98/tic98-1.01-r1.ebuild
index a72c22b2557e..534ca418999f 100644
--- a/sys-apps/tic98/tic98-1.01-r1.ebuild
+++ b/sys-apps/tic98/tic98-1.01-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/tic98-1.01-r1.ebuild,v 1.6 2004/07/15 02:41:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/tic98-1.01-r1.ebuild,v 1.7 2004/08/24 03:47:47 swegener Exp $
+
+inherit eutils
DESCRIPTION="tic98 is a compressor for black-and-white images, in particular scanned documents. It gets very good compression, better than AT&T's DjVu system. tic98 also includes ppmd text compression (ppmd) and number compression (b_gamma_enc)"
HOMEPAGE="http://www.cs.waikato.ac.nz/~singlis/"
@@ -16,8 +18,8 @@ DEPEND=""
S="${WORKDIR}/${PN}"
src_compile() {
- patch -p1 < ${FILESDIR}/${P}-gentoo.diff
- patch -p1 < $FILESDIR/${PN}.diff
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch $FILESDIR/${PN}.diff
emake all || die
emake all2 || die
}
diff --git a/sys-apps/tic98/tic98-1.01.ebuild b/sys-apps/tic98/tic98-1.01.ebuild
index 597d77ee7d26..4840d2318bc3 100644
--- a/sys-apps/tic98/tic98-1.01.ebuild
+++ b/sys-apps/tic98/tic98-1.01.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/tic98-1.01.ebuild,v 1.8 2004/07/15 02:41:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/tic98-1.01.ebuild,v 1.9 2004/08/24 03:47:47 swegener Exp $
+
+inherit eutils
DESCRIPTION="tic98 is a compressor for black-and-white images, in particular scanned documents. It gets very good compression, better than AT&T's DjVu system. tic98 also includes ppmd text compression (ppmd) and number compression (b_gamma_enc)"
HOMEPAGE="http://www.cs.waikato.ac.nz/~singlis/"
@@ -16,8 +18,8 @@ DEPEND=""
S="${WORKDIR}/${PN}"
src_compile() {
- patch -p1 < ${FILESDIR}/${P}-gentoo.diff
- patch -p1 < $FILESDIR/${PN}.diff
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch $FILESDIR/${PN}.diff
emake all || die
emake all2 || die
}