summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-08-24 14:24:07 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-08-24 14:24:07 +0000
commit8ce1244519841628932c16d3bf217d6948ffa1d2 (patch)
tree7d2d766d6c8bf39657d788c4727653e08cbcc13b /sys-apps
parentStable for amd64, wrt bug #417027 (diff)
downloadhistorical-8ce1244519841628932c16d3bf217d6948ffa1d2.tar.gz
historical-8ce1244519841628932c16d3bf217d6948ffa1d2.tar.bz2
historical-8ce1244519841628932c16d3bf217d6948ffa1d2.zip
version bump
Package-Manager: portage-2.2.0_alpha104/cvs/Linux x86_64
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/entropy-server/ChangeLog7
-rw-r--r--sys-apps/entropy-server/entropy-server-136.ebuild39
-rw-r--r--sys-apps/entropy/ChangeLog7
-rw-r--r--sys-apps/entropy/entropy-136.ebuild115
4 files changed, 166 insertions, 2 deletions
diff --git a/sys-apps/entropy-server/ChangeLog b/sys-apps/entropy-server/ChangeLog
index 72ef4f0d80c7..4712ae68bf6c 100644
--- a/sys-apps/entropy-server/ChangeLog
+++ b/sys-apps/entropy-server/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/entropy-server
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy-server/ChangeLog,v 1.18 2012/07/11 18:32:44 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy-server/ChangeLog,v 1.19 2012/08/24 14:24:07 lxnay Exp $
+
+*entropy-server-136 (24 Aug 2012)
+
+ 24 Aug 2012; Fabio Erculiani <lxnay@gentoo.org> +entropy-server-136.ebuild:
+ version bump
*entropy-server-1.0_rc124 (11 Jul 2012)
diff --git a/sys-apps/entropy-server/entropy-server-136.ebuild b/sys-apps/entropy-server/entropy-server-136.ebuild
new file mode 100644
index 000000000000..8b4a70f72b6a
--- /dev/null
+++ b/sys-apps/entropy-server/entropy-server-136.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy-server/entropy-server-136.ebuild,v 1.1 2012/08/24 14:24:07 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager server-side tools"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}/server"
+
+RDEPEND="~sys-apps/entropy-${PV}"
+DEPEND="app-text/asciidoc"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ newbashcomp "${S}/eit-completion.bash" eit
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/server"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/server"
+}
diff --git a/sys-apps/entropy/ChangeLog b/sys-apps/entropy/ChangeLog
index 572eabec0e3b..1e3dc43080df 100644
--- a/sys-apps/entropy/ChangeLog
+++ b/sys-apps/entropy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/entropy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.27 2012/07/11 18:27:27 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.28 2012/08/24 14:21:57 lxnay Exp $
+
+*entropy-136 (24 Aug 2012)
+
+ 24 Aug 2012; Fabio Erculiani <lxnay@gentoo.org> +entropy-136.ebuild:
+ version bump
11 Jul 2012; Fabio Erculiani <lxnay@gentoo.org> entropy-1.0_rc124.ebuild:
inherit user...
diff --git a/sys-apps/entropy/entropy-136.ebuild b/sys-apps/entropy/entropy-136.ebuild
new file mode 100644
index 000000000000..87911072b69b
--- /dev/null
+++ b/sys-apps/entropy/entropy-136.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/entropy-136.ebuild,v 1.1 2012/08/24 14:21:57 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
+inherit eutils python user
+
+DESCRIPTION="Entropy Package Manager foundation library"
+HOMEPAGE="http://www.sabayon.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE=""
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+RDEPEND="dev-db/sqlite[soundex]
+ net-misc/rsync
+ sys-apps/diffutils
+ sys-apps/sandbox
+ >=sys-apps/portage-2.1.9
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+REPO_CONFPATH="${ROOT}/etc/entropy/repositories.conf"
+REPO_D_CONFPATH="${ROOT}/etc/entropy/repositories.conf.d"
+ENTROPY_CACHEDIR="${ROOT}/var/lib/entropy/caches"
+
+pkg_setup() {
+ # Can:
+ # - update repos
+ # - update security advisories
+ # - handle on-disk cache (atm)
+ enewgroup entropy || die "failed to create entropy group"
+ # Create unprivileged entropy user
+ enewgroup entropy-nopriv || die "failed to create entropy-nopriv group"
+ enewuser entropy-nopriv -1 -1 -1 entropy-nopriv || die "failed to create entropy-nopriv user"
+}
+
+src_compile() {
+ cd "${S}"/client/po || die
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" entropy-install || die "make install failed"
+ cd "${S}"/client/po || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+}
+
+pkg_postinst() {
+ for ex_conf in "${REPO_D_CONFPATH}"/_entropy_sabayon-limbo.example; do
+ real_conf="${ex_conf%.example}"
+ if [ -f "${real_conf}" ] || [ -f "${real_conf/_}" ]; then
+ # skip installation then
+ continue
+ fi
+ elog "Installing: ${real_conf}"
+ cp "${ex_conf}" "${real_conf}" -p
+ done
+
+ # Copy config file over
+ if [ -f "${REPO_CONFPATH}.example" ] && [ ! -f "${REPO_CONFPATH}" ]; then
+ elog "Copying ${REPO_CONFPATH}.example over to ${REPO_CONFPATH}"
+ cp "${REPO_CONFPATH}.example" "${REPO_CONFPATH}" -p
+ fi
+
+ if [ -d "${ENTROPY_CACHEDIR}" ]; then
+ einfo "Purging current Entropy cache"
+ rm -rf "${ENTROPY_CACHEDIR}"/*
+ fi
+
+ # Fixup Entropy Resources Lock, and /etc/entropy/packages
+ # files permissions. This fixes unprivileged Entropy Library usage
+ local res_file="${ROOT}"/var/lib/entropy/client/database/*/.using_resources
+ if [ -f "${res_file}" ]; then
+ chown root:entropy "${res_file}"
+ chmod g+rw "${res_file}"
+ chmod o+r "${res_file}"
+ fi
+ local pkg_files="package.mask package.unmask package.mask.d package.unmask.d"
+ local pkg_file
+ for pkg_file in ${pkg_files}; do
+ pkg_file="${ROOT}/etc/entropy/packages/${pkg_file}"
+ recursive=""
+ if [ -d "${pkg_file}" ]; then
+ recursive="-R"
+ fi
+ if [ -e "${pkg_file}" ]; then
+ chown ${recursive} root:entropy "${pkg_file}"
+ chmod ${recursive} go+r "${pkg_file}"
+ fi
+ done
+
+ # Setup Entropy Library directories ownership
+ chown -R root:entropy "${ROOT}/var/tmp/entropy"
+ chown root:entropy "${ROOT}/var/lib/entropy" # no recursion
+ chown root:entropy "${ROOT}/var/lib/entropy/client/packages" # no recursion
+ chown root:entropy "${ROOT}/var/log/entropy" # no recursion
+
+ python_mod_optimize "/usr/lib/entropy/lib/entropy"
+
+ echo
+ elog "If you want to enable Entropy packages delta download support, please"
+ elog "install dev-util/bsdiff."
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/lib/entropy"
+}