summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-22 02:49:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-22 02:49:36 +0000
commit7256cfade5382bdf0bcb2297a40b6b81a07bdf26 (patch)
treea2e455b0542c62aceaae42ddcc445ddbd31158d2 /sys-apps/xinetd
parentRequires >=dev-libs/libxml2-2.6.17, see bug #86157 (diff)
downloadhistorical-7256cfade5382bdf0bcb2297a40b6b81a07bdf26.tar.gz
historical-7256cfade5382bdf0bcb2297a40b6b81a07bdf26.tar.bz2
historical-7256cfade5382bdf0bcb2297a40b6b81a07bdf26.zip
add gcc-4 patch #86128 by Kristiaan Lenaerts
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-apps/xinetd')
-rw-r--r--sys-apps/xinetd/Manifest3
-rw-r--r--sys-apps/xinetd/files/xinetd-2.3.13-gcc4.patch28
-rw-r--r--sys-apps/xinetd/xinetd-2.3.13.ebuild15
3 files changed, 41 insertions, 5 deletions
diff --git a/sys-apps/xinetd/Manifest b/sys-apps/xinetd/Manifest
index bcad61f1fac1..636e3e5b7032 100644
--- a/sys-apps/xinetd/Manifest
+++ b/sys-apps/xinetd/Manifest
@@ -1,6 +1,7 @@
MD5 738c06931d427117e14dccd4f911700f ChangeLog 5367
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 1a03f57ec8f70d784d822784bfa3963c xinetd-2.3.13.ebuild 1909
+MD5 0ab919c245efca6ef554559091b2ae33 xinetd-2.3.13.ebuild 1999
+MD5 04e66e7da7e59b3282511ec586d14035 files/xinetd-2.3.13-gcc4.patch 893
MD5 897e24c3c7cc5a08093dfcb3a71fc0ee files/xconv.pl 3030
MD5 ccad3f7878ea7a1e078796419717c4b2 files/xinetd.conf 459
MD5 1f24b28f485355ae6fa0f9e4008553c5 files/xinetd.confd 289
diff --git a/sys-apps/xinetd/files/xinetd-2.3.13-gcc4.patch b/sys-apps/xinetd/files/xinetd-2.3.13-gcc4.patch
new file mode 100644
index 000000000000..80a7bfda84a9
--- /dev/null
+++ b/sys-apps/xinetd/files/xinetd-2.3.13-gcc4.patch
@@ -0,0 +1,28 @@
+Fixes from upstream CVS for gcc-4.x.
+
+http://bugs.gentoo.org/show_bug.cgi?id=86128
+
+--- xinetd/service.c
++++ xinetd/service.c
+@@ -764,8 +764,8 @@
+ return FAILED;
+
+ if ( last == NULL ) {
+- last = SAIN( SVC_LAST_DGRAM_ADDR(sp) ) =
+- SAIN( calloc( 1, sizeof(union xsockaddr) ) );
++ last = SAIN( calloc( 1, sizeof(union xsockaddr) ) );
++ SVC_LAST_DGRAM_ADDR(sp) = (union xsockaddr *)last;
+ }
+
+ (void) time( &current_time ) ;
+@@ -791,8 +791,8 @@
+ return FAILED;
+
+ if( last == NULL ) {
+- last = SAIN6(SVC_LAST_DGRAM_ADDR(sp)) =
+- SAIN6(calloc( 1, sizeof(union xsockaddr) ) );
++ last = SAIN6(calloc( 1, sizeof(union xsockaddr) ) );
++ SVC_LAST_DGRAM_ADDR( sp ) = (union xsockaddr *)last;
+ }
+
+ (void) time( &current_time ) ;
diff --git a/sys-apps/xinetd/xinetd-2.3.13.ebuild b/sys-apps/xinetd/xinetd-2.3.13.ebuild
index 3737f7fc4792..feb92bb42d13 100644
--- a/sys-apps/xinetd/xinetd-2.3.13.ebuild
+++ b/sys-apps/xinetd/xinetd-2.3.13.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.13.ebuild,v 1.13 2005/02/22 22:58:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.13.ebuild,v 1.14 2005/03/22 02:49:36 vapier Exp $
+
+inherit eutils
DESCRIPTION="powerful replacement for inetd"
HOMEPAGE="http://www.xinetd.org/"
@@ -8,15 +10,20 @@ SRC_URI="http://www.xinetd.org/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE="tcpd"
-DEPEND="virtual/libc
- tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+DEPEND="tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
RDEPEND="${DEPEND}
dev-lang/perl"
PROVIDE="virtual/inetd"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_compile() {
local myconf
use tcpd && myconf="--with-libwrap"