summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-25 23:39:54 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-25 23:39:54 +0000
commite4b1d2cbeba8b0d1169e4ecc5a9b8222527aefe1 (patch)
treee83259edfcf18886593e529f160ba5e48ed88e66 /sys-apps/tpctl
parentnew sudo ebuild - security fix (see bugtraq) (diff)
downloadhistorical-e4b1d2cbeba8b0d1169e4ecc5a9b8222527aefe1.tar.gz
historical-e4b1d2cbeba8b0d1169e4ecc5a9b8222527aefe1.tar.bz2
historical-e4b1d2cbeba8b0d1169e4ecc5a9b8222527aefe1.zip
New package
Diffstat (limited to 'sys-apps/tpctl')
-rw-r--r--sys-apps/tpctl/ChangeLog13
-rw-r--r--sys-apps/tpctl/files/apmiser.rc18
-rw-r--r--sys-apps/tpctl/files/digest-tpctl-3.21
-rw-r--r--sys-apps/tpctl/tpctl-3.2.ebuild55
4 files changed, 87 insertions, 0 deletions
diff --git a/sys-apps/tpctl/ChangeLog b/sys-apps/tpctl/ChangeLog
new file mode 100644
index 000000000000..8c2f36681141
--- /dev/null
+++ b/sys-apps/tpctl/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sys-apps/tpctl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/ChangeLog,v 1.1 2002/04/25 23:39:54 rphillips Exp $
+
+*tpctl-3.2 (25 April 2002)
+
+ 25 April 2002; Wout Mertens <Wout.Mertens@advalvas.be> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/sys-apps/tpctl/files/apmiser.rc b/sys-apps/tpctl/files/apmiser.rc
new file mode 100644
index 000000000000..bfd8578e630e
--- /dev/null
+++ b/sys-apps/tpctl/files/apmiser.rc
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/files/apmiser.rc,v 1.1 2002/04/25 23:39:54 rphillips Exp $
+
+
+start() {
+ ebegin "Starting Thinkpad Battery Maximiser"
+ start-stop-daemon --start --background --quiet --make-pidfile \
+ --pidfile /var/run/apmiser.pid --exec /usr/sbin/apmiser
+ eend $?
+}
+
+stop () {
+ ebegin "Shutting down Thinkpad Battery Maximiser"
+ start-stop-daemon --stop --quiet --pid /var/run/apmiser.pid
+ eend $?
+}
diff --git a/sys-apps/tpctl/files/digest-tpctl-3.2 b/sys-apps/tpctl/files/digest-tpctl-3.2
new file mode 100644
index 000000000000..8905ea02c42b
--- /dev/null
+++ b/sys-apps/tpctl/files/digest-tpctl-3.2
@@ -0,0 +1 @@
+MD5 340b45ee11f925374753fddbae0300fa tpctl_3.2.tar.gz 79506
diff --git a/sys-apps/tpctl/tpctl-3.2.ebuild b/sys-apps/tpctl/tpctl-3.2.ebuild
new file mode 100644
index 000000000000..a1db525ea626
--- /dev/null
+++ b/sys-apps/tpctl/tpctl-3.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Wout Mertens <Wout.Mertens@advalvas.be>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/tpctl-3.2.ebuild,v 1.1 2002/04/25 23:39:54 rphillips Exp $
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+KV=""
+
+DESCRIPTION="Thinkpad system control user space programs"
+SRC_URI="http://prdownloads.sourceforge.net/tpctl/${MYP}.tar.gz"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+
+DEPEND="$DEPEND sys-apps/thinkpad ncurses? ( sys-libs/ncurses )"
+RDEPEND="$RDEPEND sys-apps/thinkpad ncurses? ( sys-libs/ncurses ) perl? ( sys-devel/perl )"
+
+src_compile() {
+
+ emake -C lib || die "lib make failed"
+ emake -C tpctl || die "tpctl make failed"
+ if use ncurses > /dev/null; then
+ emake -C ntpctl || die "ntpctl make failed"
+ fi
+
+ # Only for thinkpad models 760 and 765
+ # build with:
+ # $ USE=tpctlir emerge tpctl
+ if use tpctlir > /dev/null; then
+ emake -C tpctlir || die "tpctlir make failed"
+ fi
+
+}
+
+src_install () {
+
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING \
+ VGA-MODES
+ dolib lib/libsmapidev.so.1.0
+ dobin tpctl/tpctl
+ [ -e ntpctl/ntpctl ] && dobin ntpctl/ntpctl
+ if use tpctlir > /dev/null && [ -e tpctlir/tpctlir ]; then
+ mv tpctlir/README README.tpctlir
+ dodoc README.tpctlir
+ dobin tpctlir/tpctlir
+ fi
+ if use perl > /dev/null; then
+ mv apmiser/README README.apmiser
+ dodoc README.apmiser
+ dosbin apmiser/apmiser
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/apmiser.rc apmiser
+ fi
+
+}