summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-11-26 07:20:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-11-26 07:20:29 +0000
commit78912561831b9f86b61e5727d03f1ef7c06ff027 (patch)
treeb4d94172101cd9c79fab2a6e8daf68bdc751e882 /sys-apps/sg3_utils
parentFix libX11 xcb USE flag dependency since >=x11-libs/libX11-1.4.0 comes with x... (diff)
downloadhistorical-78912561831b9f86b61e5727d03f1ef7c06ff027.tar.gz
historical-78912561831b9f86b61e5727d03f1ef7c06ff027.tar.bz2
historical-78912561831b9f86b61e5727d03f1ef7c06ff027.zip
Version bump.
Package-Manager: portage-2.2.0_alpha5/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/ChangeLog7
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.30.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index 31a010a99d66..11e3aeb45432 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.69 2010/10/29 06:22:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.70 2010/11/26 07:20:29 robbat2 Exp $
+
+*sg3_utils-1.30 (26 Nov 2010)
+
+ 26 Nov 2010; Robin H. Johnson <robbat2@gentoo.org> +sg3_utils-1.30.ebuild:
+ Version bump.
29 Oct 2010; Jeroen Roovers <jer@gentoo.org> sg3_utils-1.29.ebuild:
Stable for HPPA (bug #329621).
diff --git a/sys-apps/sg3_utils/sg3_utils-1.30.ebuild b/sys-apps/sg3_utils/sg3_utils-1.30.ebuild
new file mode 100644
index 000000000000..59cb16f4c9d7
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.30.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.30.ebuild,v 1.1 2010/11/26 07:20:29 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool"
+RDEPEND="sys-apps/sdparm"
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog AUTHORS COVERAGE CREDITS README*
+ dodoc doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+ dosbin scripts/scsi* || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${D}"/usr/$(get_libdir)/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}