summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-07 15:54:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-07 15:54:34 +0000
commit8f9c6a96ba329f41ece75794f0fc1d5f286e5747 (patch)
tree9e1fd67b580da4a8aa59947a7248245718646d57 /sys-apps/sed
parentadded fix for ximian's openoffice apps (diff)
downloadhistorical-8f9c6a96ba329f41ece75794f0fc1d5f286e5747.tar.gz
historical-8f9c6a96ba329f41ece75794f0fc1d5f286e5747.tar.bz2
historical-8f9c6a96ba329f41ece75794f0fc1d5f286e5747.zip
dont try to bootstrap sed if USE="bootstrap build" and use type -p instead of which (THX SOLAR I LUB J00)
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/Manifest10
-rw-r--r--sys-apps/sed/sed-4.0.9.ebuild16
-rw-r--r--sys-apps/sed/sed-4.1.2.ebuild16
3 files changed, 23 insertions, 19 deletions
diff --git a/sys-apps/sed/Manifest b/sys-apps/sed/Manifest
index ceb6647e41db..4bdbff610624 100644
--- a/sys-apps/sed/Manifest
+++ b/sys-apps/sed/Manifest
@@ -3,8 +3,8 @@ Hash: SHA1
MD5 a061972319122050e43c6e3c6db88a8b ChangeLog 8080
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 1fa3660c3a81c8b04f21174ffa305a9a sed-4.1.2.ebuild 1784
-MD5 f43ec14cdbc4c750e782a9cf49f07309 sed-4.0.9.ebuild 1779
+MD5 acfa8abd84130788db5507942e549596 sed-4.1.2.ebuild 1835
+MD5 8f388c6c0928f2280672d775ec595b05 sed-4.0.9.ebuild 1830
MD5 da2101c043ce802aabb650bea031a52d files/digest-sed-4.1.2 61
MD5 1f789b81b2d7992345e1490c68ad5477 files/dos2unix 59
MD5 2502535e2cc93fa49d1c2fdc31eff1b2 files/unix2dos 56
@@ -12,7 +12,7 @@ MD5 a244109e1adcbd40a02446fb23df33c1 files/digest-sed-4.0.9 61
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBX79RHTu7gpaalycRAm5JAJ0ekEO0tow3Mt5d3smH1e8nGHemLACgmdea
-yWs/7Pvw4wRtB8BTnIaZof8=
-=TRx4
+iD8DBQFBZWbGHTu7gpaalycRAtHxAKCNONd9ZvpaAfNr4STTZd0VsJyWcgCg2Xra
+YtDHI7/V5DcR25xG/8khoyU=
+=+Xre
-----END PGP SIGNATURE-----
diff --git a/sys-apps/sed/sed-4.0.9.ebuild b/sys-apps/sed/sed-4.0.9.ebuild
index a1f1193bb573..b96b4534870b 100644
--- a/sys-apps/sed/sed-4.0.9.ebuild
+++ b/sys-apps/sed/sed-4.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.26 2004/10/03 08:58:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.27 2004/10/07 15:54:34 vapier Exp $
inherit gnuconfig flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/sed/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha arm amd64 hppa ia64 macos mips ppc ppc64 ppc-macos s390 sparc x86"
-IUSE="nls static build"
+IUSE="nls static build bootstrap"
RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
@@ -26,11 +26,13 @@ src_unpack() {
src_compile() {
# make sure system-sed works #40786
export NO_SYS_SED=""
- if ! which sed >& /dev/null ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed ${T}/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
+ if ! use bootstrap && ! use build ; then
+ if ! type -p sed ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed ${T}/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ fi
fi
local myconf=""
diff --git a/sys-apps/sed/sed-4.1.2.ebuild b/sys-apps/sed/sed-4.1.2.ebuild
index 72f7177ae6f1..5659cc07d28a 100644
--- a/sys-apps/sed/sed-4.1.2.ebuild
+++ b/sys-apps/sed/sed-4.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.2.ebuild,v 1.5 2004/10/03 08:58:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.2.ebuild,v 1.6 2004/10/07 15:54:34 vapier Exp $
inherit gnuconfig flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/sed/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~arm ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sparc ~x86"
-IUSE="nls static build"
+IUSE="nls static build bootstrap"
RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
@@ -26,11 +26,13 @@ src_unpack() {
src_compile() {
# make sure system-sed works #40786
export NO_SYS_SED=""
- if ! which sed >& /dev/null ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed ${T}/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
+ if ! use bootstrap && ! use build ; then
+ if ! type -p sed ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed ${T}/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ fi
fi
local myconf=""