summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2003-01-23 08:14:12 +0000
committerChad Huneycutt <chadh@gentoo.org>2003-01-23 08:14:12 +0000
commit60954f5d9f8dce5b2be23025c58a8bcd3690d33a (patch)
tree50d50013d204c5953b5686ee95dbf632f63e65aa /sys-apps/pcmcia-cs-drivers
parentadded pcmcia-cs-tools and pcmcia-cs-drivers. These need approval and testing (diff)
downloadhistorical-60954f5d9f8dce5b2be23025c58a8bcd3690d33a.tar.gz
historical-60954f5d9f8dce5b2be23025c58a8bcd3690d33a.tar.bz2
historical-60954f5d9f8dce5b2be23025c58a8bcd3690d33a.zip
new pcmcia-cs ebuild. This installs just the modules provided by that package.
Diffstat (limited to 'sys-apps/pcmcia-cs-drivers')
-rw-r--r--sys-apps/pcmcia-cs-drivers/files/digest-pcmcia-cs-drivers-3.2.31
-rw-r--r--sys-apps/pcmcia-cs-drivers/files/hermes.conf74
-rw-r--r--sys-apps/pcmcia-cs-drivers/files/ppc.config.opts9
-rw-r--r--sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.3.ebuild131
4 files changed, 215 insertions, 0 deletions
diff --git a/sys-apps/pcmcia-cs-drivers/files/digest-pcmcia-cs-drivers-3.2.3 b/sys-apps/pcmcia-cs-drivers/files/digest-pcmcia-cs-drivers-3.2.3
new file mode 100644
index 000000000000..7bfa1c669683
--- /dev/null
+++ b/sys-apps/pcmcia-cs-drivers/files/digest-pcmcia-cs-drivers-3.2.3
@@ -0,0 +1 @@
+MD5 581749071efdfc8056ed05f0373d5b79 pcmcia-cs-3.2.3.tar.gz 1255022
diff --git a/sys-apps/pcmcia-cs-drivers/files/hermes.conf b/sys-apps/pcmcia-cs-drivers/files/hermes.conf
new file mode 100644
index 000000000000..df1b30515f47
--- /dev/null
+++ b/sys-apps/pcmcia-cs-drivers/files/hermes.conf
@@ -0,0 +1,74 @@
+device "orinoco_cs"
+ class "network"
+ module "hermes", "orinoco", "orinoco_cs"
+# module "hermes", "orinoco" opts "pc_debug=3", "orinoco_cs"
+
+#
+# Wireless network adapters
+#
+# We should use the manfid (which cover multiple cards), otherwise we will
+# go crazy listing all cards and their variations !!!
+
+# First class of device : Lucent & OEM
+card "Lucent Technologies Orinoco"
+ manfid 0x0156,0x0002
+ bind "orinoco_cs"
+
+card "Lucent Technologies Wavelan/IEEE"
+ version "Lucent Technologies", "WaveLAN/IEEE"
+ bind "orinoco_cs"
+
+card "Cabletron RoamAbout 802.11 DS"
+ version "Cabletron", "RoamAbout 802.11 DS"
+ bind "orinoco_cs"
+
+card "ELSA AirLancer MC-11"
+ version "ELSA", "AirLancer MC-11"
+ bind "orinoco_cs"
+
+card "MELCO WLI-PCM-L11"
+ version "MELCO", "WLI-PCM-L11"
+ bind "wvlan_cs"
+
+# Second class of device : Symbol & OEM
+card "LA4111 Spectrum24 Wireless LAN PC Card"
+ version "Symbol Technologies"
+ bind "orinoco_cs"
+
+card "3Com AirConnect"
+ version "3Com", "3CRWE737A AirConnect Wireless LAN PC Card"
+ bind "orinoco_cs"
+
+card "Intel PRO/Wireless 2011"
+ manfid 0x0089,0x0001
+ bind "orinoco_cs"
+
+card "Ericsson WLAN Card C11"
+ manfid 0x016b,0x0001
+ bind "orinoco_cs"
+
+# Third class of device : other Intersil clones
+card "Intersil PRISM2 11 Mbps Wireless Adapter"
+ manfid 0x0156, 0x0002
+ bind "orinoco_cs"
+
+card "Farallon SkyLINE"
+ version "INTERSIL", "HFA384x/IEEE"
+ bind "orinoco_cs"
+
+card "D-Link DWL-650"
+ version "D", "Link DWL-650 11Mbps WLAN Card"
+ bind "orinoco_cs"
+
+card "SAMSUNG 11Mbps WLAN Card"
+ version "SAMSUNG", "11Mbps WLAN Card"
+ bind "orinoco_cs"
+# Does this one cover Compaq as well ???
+
+card "HyperLink Wireless PC Card 11Mbps"
+ version "HyperLink","Wireless PC Card 11Mbps"
+ bind "orinoco_cs"
+
+card "PROXIM LAN PC CARD HARMONY 80211B"
+ version "PROXIM","LAN PC CARD HARMONY 80211B"
+ bind "orinoco_cs"
diff --git a/sys-apps/pcmcia-cs-drivers/files/ppc.config.opts b/sys-apps/pcmcia-cs-drivers/files/ppc.config.opts
new file mode 100644
index 000000000000..3df34ee7529b
--- /dev/null
+++ b/sys-apps/pcmcia-cs-drivers/files/ppc.config.opts
@@ -0,0 +1,9 @@
+#
+# Local PCMCIA Configuration File
+#
+#----------------------------------------------------------------------
+
+include port 0x1000-0x1fff
+include memory 0x90000000-0x9003ffff
+
+# all other modules should be kernel modules on ppc
diff --git a/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.3.ebuild b/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.3.ebuild
new file mode 100644
index 000000000000..4404e5323338
--- /dev/null
+++ b/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.3.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.3.ebuild,v 1.1 2003/01/23 08:14:12 chadh Exp $
+
+P=${P/-drivers/}
+S=${WORKDIR}/${P}
+DESCRIPTION="pcmcia-cs drivers"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz"
+
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+SLOT="0"
+IUSE="trusted apm pnp nocardbus build"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# check arch for configure
+if [ ${ARCH} = "x86" ] ; then
+ MY_ARCH="i386"
+else
+ MY_ARCH="ppc"
+fi
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ unpack orinoco-0.13a.tar.gz
+ mv orinoco-0.13a/hermes*.{c,h} \
+ orinoco-0.13a/orinoco*.{c,h} \
+ orinoco-0.13a/ieee802_11.h \
+ ${P}/wireless/
+
+ cd ${S}
+ cp Configure Configure.orig
+ sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
+ #man pages will now install into /usr/share/man
+
+ echo `use gtk`
+}
+
+src_compile() {
+ local myconf
+ use trusted && myconf="--trust" || myconf="--notrust"
+ use apm && myconf="$myconf --apm" || myconf="$myconf --noapm"
+ use pnp && myconf="$myconf --pnp" || myconf="$myconf --nopnp"
+ use nocardbus && myconf="$myconf --nocardbus" || myconf="$myconf --cardbus"
+
+ #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
+ ./Configure -n \
+ --force \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${MY_ARCH}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+ # nopnp and noapm are important, because without them the pcmcia-cs
+ # tools will require a kernel with ISA PnP and/or APM support,
+ # which cannot be guaranteed. We need to make sure the tools
+ # work *all* the time, not just some of the time.
+
+ # The --srctree option tells pcmcia-cs to configure for the kernel in
+ # /usr/src/linux rather than the currently-running kernel. It's Gentoo
+ # Linux policy to configure for the kernel in /usr/src/linux
+
+ # This handles the various cardinfo guis. If you have gtk in your USE,
+ # then the gtk version will be installed. If not, but X is in your USE,
+ # then the xaw version will be installed. Otherwise, no gui will be
+ # installed.
+ sed -e "/^HAS_FORMS/d" config.out > config.out.1
+ sed -e "/^HAS_FORMS/d" config.mk > config.mk.1
+ sed -i -e "/^HAS_GTK/d" config.out.1
+ sed -i -e "/^HAS_GTK/d" config.mk.1
+ sed -i -e "/^HAS_XAW/d" config.out.1
+ sed -i -e "/^HAS_XAW/d" config.mk.1
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.out.1 > config.out
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.mk.1 > config.mk
+ rm -f config.out.1
+ rm -f config.mk.1
+
+
+ # patch version.h so that they won't complain that Card Services is wrong.
+ if [ -n "`grep -E '^CONFIG_PCMCIA\=y' config.mk`" ]; then
+ cd ${S}/include/pcmcia
+
+ # get kernel CS_RELEASE :
+ if [ -f /usr/src/linux/include/pcmcia/version.h ]; then
+ KERNEL_RELEASE=`grep -E '^#define CS_RELEASE ' /usr/src/linux/include/pcmcia/version.h | awk '{print $3}'`
+ KERNEL_RELEASE_CODE=`grep -E '^#define CS_RELEASE_CODE ' /usr/src/linux/include/pcmcia/version.h | awk '{print $3}'`
+ else
+ die "unable to find /usr/src/linux/include/pcmcia/version.h"
+ fi
+
+ # replace CS_PKG_RELEASE :
+ if [ -f version.h ]; then
+ sed "s|\(#define CS_PKG_RELEASE.*\)\".*\"|\1$KERNEL_RELEASE|" version.h > version.h.new
+ sed "s|\(#define CS_PKG_RELEASE_CODE.*\)0x.*|\1$KERNEL_RELEASE_CODE|" version.h.new > version.h
+ fi
+
+ cd ${S}/clients
+ emake all || die "failed compiling"
+ cd ${S}/wireless
+ emake all || die "failed compiling"
+ else
+ eerror "Please enable PCMCIA in your kernel in /usr/src/linux"
+ eend
+ fi
+
+}
+
+src_install () {
+ cd ${S}/clients
+ make PREFIX=${D} install || die "failed installing"
+ cd ${S}/wireless
+ make PREFIX=${D} install || die "failed installing"
+ cd ${S}/man
+ make PREFIX=${D} install-man4 || die "failed installing"
+
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+}
+
+pkg_postinst() {
+ einfo "Please note that some of these drivers are also provided by the kernel. To use a driver installed"
+ einfo "by this ebuild, you must *disable* the corresponding driver in the kernel."
+}