summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-06-03 22:11:31 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-06-03 22:11:31 +0000
commita318c0049ba5711019fa872c1d29cba5e988e8c6 (patch)
treedbd4f59a10ed891bee7dbd7261eaaf718d29e965 /sys-apps/memtest86
parentFixes #1689 (diff)
downloadhistorical-a318c0049ba5711019fa872c1d29cba5e988e8c6.tar.gz
historical-a318c0049ba5711019fa872c1d29cba5e988e8c6.tar.bz2
historical-a318c0049ba5711019fa872c1d29cba5e988e8c6.zip
Fixes #2172.
Diffstat (limited to 'sys-apps/memtest86')
-rw-r--r--sys-apps/memtest86/ChangeLog14
-rw-r--r--sys-apps/memtest86/files/digest-memtest86-3.01
-rw-r--r--sys-apps/memtest86/memtest86-3.0.ebuild56
3 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/memtest86/ChangeLog b/sys-apps/memtest86/ChangeLog
new file mode 100644
index 000000000000..8f08a1fa7edd
--- /dev/null
+++ b/sys-apps/memtest86/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for sys-apps/memtest86
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.1 2002/06/03 22:11:31 karltk Exp $
+
+*memtest86-3.0 (03 Jun 2002)
+
+ 03 Jun 2002; Karl Trygve Kalleberg <karltk@gentoo.org> memtest86-3.0.ebuild files/digest-memtest86-3.0 :
+
+ Memtest86 is thorough, stand alone memory test for x86 architecture
+ computers. BIOS based memory tests are only a quick check and often miss
+ many of the failures that are detected by Memtest86.
+
+ Ebuild submitted by Alastair Nicol <ifni@blueyonder.co.uk>.
+
diff --git a/sys-apps/memtest86/files/digest-memtest86-3.0 b/sys-apps/memtest86/files/digest-memtest86-3.0
new file mode 100644
index 000000000000..4fb55f53126a
--- /dev/null
+++ b/sys-apps/memtest86/files/digest-memtest86-3.0
@@ -0,0 +1 @@
+MD5 fade21758538a5468ad9b8509edfde0d memtest86-3.0.tar.gz 104794
diff --git a/sys-apps/memtest86/memtest86-3.0.ebuild b/sys-apps/memtest86/memtest86-3.0.ebuild
new file mode 100644
index 000000000000..cfb1dbf6191e
--- /dev/null
+++ b/sys-apps/memtest86/memtest86-3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Alastair Nicol <ifni@blueyonder.co.uk>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A stand alone memory test for x86 computers"
+SRC_URI="http://www.teresaudio.com/memtest86/${P}.tar.gz"
+HOMEPAGE="http://www.teresaudio.com/memtest86/"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+RDEPEND=""
+
+pkg_setup() {
+ [ "$ROOT" != "/" ] && return 0
+ #If the user doesn't have a /boot or /mnt/boot filesystem, skip.
+ [ -z "`grep /boot /etc/fstab | grep -v "^[ \t]*#"`" ] || return 0
+ local myboot
+ myboot=`cat /etc/fstab | grep -v ^# | grep /boot | sed -e 's/^[^[:space:]]*[[:space:]]*\([^[:space:]]*\).*$/\1/'`
+ [ `cat /proc/mounts | cut -f2 -d" " | grep $myboot` ] && return 0
+ mount $myboot
+ if [ $? -ne 0 ]
+ then
+ eerror "MEMTEST86 installation requires that $myboot is mounted or mountable."
+ eerror "If you do not have a seperate /boot partition please remove any"
+ eerror "/boot entries from /etc/fstab and make sure /boot exists."
+ eerror ""
+ eerror "Unable to mount $myboot automatically; exiting."
+ die "Please mount your $myboot filesystema and remerge this ebuild."
+ fi
+}
+
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+
+ dodir /boot/memtest86
+ cp memtest.bin ${D}/boot/memtest86
+
+ dodoc README README.build-process
+
+}
+
+pkg_postinst() {
+
+ einfo '*** memtest.bin has been installed in /boot/memtest86, please remember to'
+ einfo '*** update your boot loader. For example grub :'
+ einfo "*** edit /boot/grub/menu.lst and add the following lines "
+ einfo "*** > title=Memtest86"
+ einfo "*** > root (hd0,0)"
+ einfo "*** > kernel /boot/memtest86/memtest.bin"
+}