summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2009-11-23 23:37:04 +0000
committerMichael Januszewski <spock@gentoo.org>2009-11-23 23:37:04 +0000
commit7fa8687e7d48a76fd7d537e7f3924273b94b417d (patch)
treee3b470407cd18790f7c98b139c45539e8ef44503 /sys-apps/memtest86+/memtest86+-4.00.ebuild
parentFix build with latest jack, bug #294226 (diff)
downloadhistorical-7fa8687e7d48a76fd7d537e7f3924273b94b417d.tar.gz
historical-7fa8687e7d48a76fd7d537e7f3924273b94b417d.tar.bz2
historical-7fa8687e7d48a76fd7d537e7f3924273b94b417d.zip
Install the ELF binary along with the Linux kernel one (bug #291729).
Package-Manager: portage-2.2_rc51/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/memtest86+/memtest86+-4.00.ebuild')
-rw-r--r--sys-apps/memtest86+/memtest86+-4.00.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-apps/memtest86+/memtest86+-4.00.ebuild b/sys-apps/memtest86+/memtest86+-4.00.ebuild
index d6bf7f4d15db..31905e7621e5 100644
--- a/sys-apps/memtest86+/memtest86+-4.00.ebuild
+++ b/sys-apps/memtest86+/memtest86+-4.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-4.00.ebuild,v 1.5 2009/11/22 16:49:54 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-4.00.ebuild,v 1.6 2009/11/23 23:37:04 spock Exp $
QA_PRESTRIPPED=/boot/memtest86plus/memtest
@@ -28,6 +28,7 @@ src_unpack() {
# Merged upstream
#epatch "${FILESDIR}"/${PN}-1.70-gnu_hash.patch
+ sed -i -e's/$(LD) -s /$(LD) /' Makefile
sed -i -e's,0x10000,0x100000,' memtest.lds
if use serial ; then
@@ -42,6 +43,7 @@ src_compile() {
src_install() {
insinto /boot/memtest86plus
newins memtest.bin memtest || die
+ newins memtest memtest.netbsd || die
dosym memtest /boot/memtest86plus/memtest.bin
dodoc README README.build-process
@@ -56,12 +58,15 @@ pkg_postinst() {
einfo "memtest has been installed in /boot/memtest86plus/"
einfo "You may wish to update your bootloader configs"
einfo "by adding these lines:"
-
einfo " - For grub: (replace '?' with correct numbers for your boot partition)"
einfo " > title=Memtest86Plus"
einfo " > root (hd?,?)"
einfo " > kernel /boot/memtest86plus/memtest"
-
+ einfo " or try this if you get grub error 28:"
+ einfo " > title=Memtest86Plus"
+ einfo " > root (hd?,?)"
+ einfo " > kernel --type=netbsd /boot/memtest86plus/memtest.netbsd"
+ einfo
einfo " - For lilo:"
einfo " > image = /boot/memtest86plus/memtest"
einfo " > label = Memtest86Plus"