summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-12-22 17:54:54 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-12-22 17:54:54 +0000
commitc203d69127603e8c64b0f3008a24f63ec844571d (patch)
tree796ec1b83d8c30f1ad7a7fa61cf9fe32eddd6af9 /sys-apps/magneto-core
parentversion bump (diff)
downloadhistorical-c203d69127603e8c64b0f3008a24f63ec844571d.tar.gz
historical-c203d69127603e8c64b0f3008a24f63ec844571d.tar.bz2
historical-c203d69127603e8c64b0f3008a24f63ec844571d.zip
version bump
Package-Manager: portage-2.2.0_alpha78/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/magneto-core')
-rw-r--r--sys-apps/magneto-core/ChangeLog8
-rw-r--r--sys-apps/magneto-core/magneto-core-1.0_rc80.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-apps/magneto-core/ChangeLog b/sys-apps/magneto-core/ChangeLog
index ed9178776270..4dac1161bc6e 100644
--- a/sys-apps/magneto-core/ChangeLog
+++ b/sys-apps/magneto-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/magneto-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/ChangeLog,v 1.14 2011/11/23 21:55:09 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/ChangeLog,v 1.15 2011/12/22 17:54:54 lxnay Exp $
+
+*magneto-core-1.0_rc80 (22 Dec 2011)
+
+ 22 Dec 2011; Fabio Erculiani <lxnay@gentoo.org>
+ +magneto-core-1.0_rc80.ebuild:
+ version bump
*magneto-core-1.0_rc77 (23 Nov 2011)
diff --git a/sys-apps/magneto-core/magneto-core-1.0_rc80.ebuild b/sys-apps/magneto-core/magneto-core-1.0_rc80.ebuild
new file mode 100644
index 000000000000..6d14f427b2da
--- /dev/null
+++ b/sys-apps/magneto-core/magneto-core-1.0_rc80.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/magneto-core-1.0_rc80.ebuild,v 1.1 2011/12/22 17:54:54 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python multilib
+
+DESCRIPTION="Entropy Package Manager notification applet library"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+DEPEND=">=sys-apps/entropy-client-services-${PV}"
+RDEPEND="${DEPEND}
+ x11-misc/xdg-utils"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-core-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/entropy/magneto"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/entropy/magneto"
+}