summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-01-20 20:16:52 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-01-20 20:16:52 +0000
commit05d400d3e56e4b9c92ab01b1f0a34bf63b7d7164 (patch)
treea10acf32026dce7de9d5a55ff040a7e183cb801a /sys-apps/i2c
parentdep change (diff)
downloadhistorical-05d400d3e56e4b9c92ab01b1f0a34bf63b7d7164.tar.gz
historical-05d400d3e56e4b9c92ab01b1f0a34bf63b7d7164.tar.bz2
historical-05d400d3e56e4b9c92ab01b1f0a34bf63b7d7164.zip
bump
Diffstat (limited to 'sys-apps/i2c')
-rw-r--r--sys-apps/i2c/ChangeLog8
-rw-r--r--sys-apps/i2c/files/digest-i2c-2.7.01
-rw-r--r--sys-apps/i2c/i2c-2.7.0.ebuild39
3 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/i2c/ChangeLog b/sys-apps/i2c/ChangeLog
index 5cb060cda72f..3df00b9a95d8 100644
--- a/sys-apps/i2c/ChangeLog
+++ b/sys-apps/i2c/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/i2c
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/ChangeLog,v 1.1 2002/12/08 21:30:32 sethbc Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/ChangeLog,v 1.2 2003/01/20 20:16:52 lostlogic Exp $
+
+*i2c-2.7.0 (20 Jan 2003):
+
+ 20 Jan 2003; Brandon Low <lostlogic@gentoo.org>: i2c-2.7.0.ebuild
+ Update to latest version, unstable marked for a few days, although
+ this code is well tested in the lolo and gentoo-sources.
*i2c-2.6.5 (08 Dec 2002):
08 Dec 2002; Seth Chandler <sethbc@gentoo.org>: i2c-2.6.5-r1.ebuild
diff --git a/sys-apps/i2c/files/digest-i2c-2.7.0 b/sys-apps/i2c/files/digest-i2c-2.7.0
new file mode 100644
index 000000000000..041c1b240293
--- /dev/null
+++ b/sys-apps/i2c/files/digest-i2c-2.7.0
@@ -0,0 +1 @@
+MD5 427a5ca20fe1f78c42696daeda8fb44b i2c-2.7.0.tar.gz 122846
diff --git a/sys-apps/i2c/i2c-2.7.0.ebuild b/sys-apps/i2c/i2c-2.7.0.ebuild
new file mode 100644
index 000000000000..6d67c3410b03
--- /dev/null
+++ b/sys-apps/i2c/i2c-2.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.7.0.ebuild,v 1.1 2003/01/20 20:16:52 lostlogic Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="I2C Bus support"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile () {
+ emake LINUX_INCLUDE_DIR=/usr/include/linux clean all || \
+ die "i2c requires the source of a compatible kernel\nversion installed in /usr/src/linux\nand kernel i2c *disabled* or *enabled as a module*"
+}
+
+src_install () {
+ emake LINUX_INCLUDE_DIR=/usr/include/linux DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+ dodoc CHANGES INSTALL README
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo "*****************************************************************"
+ einfo
+ einfo "i2c package installed ..."
+ einfo
+ einfo "IMPORTANT ... if you are installing this package you need to either"
+ einfo "IMPORTANT ... *disable* kernel i2c support or *enable it as a module*"
+ einfo
+ einfo "*****************************************************************"
+}
+
+