summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2003-09-06 16:27:48 +0000
committerAlexander Gabert <pappy@gentoo.org>2003-09-06 16:27:48 +0000
commitf6f309309e1aea82cf8c40510f23148a9c0fc9ce (patch)
treee67cfe403c82165c56335788052ef7b23a399152 /sys-apps/grub
parentadded hardened-gcc exclusion flags (diff)
downloadhistorical-f6f309309e1aea82cf8c40510f23148a9c0fc9ce.tar.gz
historical-f6f309309e1aea82cf8c40510f23148a9c0fc9ce.tar.bz2
historical-f6f309309e1aea82cf8c40510f23148a9c0fc9ce.zip
added hardened-gcc exclusion flags
Diffstat (limited to 'sys-apps/grub')
-rw-r--r--sys-apps/grub/Manifest4
-rw-r--r--sys-apps/grub/grub-0.93.20030118.ebuild9
2 files changed, 10 insertions, 3 deletions
diff --git a/sys-apps/grub/Manifest b/sys-apps/grub/Manifest
index c604b1b7a574..e1fac4748ac4 100644
--- a/sys-apps/grub/Manifest
+++ b/sys-apps/grub/Manifest
@@ -1,6 +1,6 @@
-MD5 7dcb77cf9eef2c8fe0d8a26992768290 ChangeLog 4598
+MD5 228e5f350ee84f3c23aa2ee443aa3574 ChangeLog 4597
MD5 8381f5e187ea676de5cc11968c0e409d grub-0.92-r1.ebuild 3207
-MD5 04bff2ea28ca958100da71cd280b6911 grub-0.93.20030118.ebuild 2344
+MD5 f37b93b6ba01d006867299c1b41e3947 grub-0.93.20030118.ebuild 2343
MD5 ca87163749e014bc3424d53c6bd76dce files/digest-grub-0.92-r1 1680
MD5 b302edf756d9f8996d9e1ae6d3a49768 files/digest-grub-0.93.20030118 1764
MD5 cdd6c89d48982ecd544c0b4774755afd files/splash.xpm.gz 33856
diff --git a/sys-apps/grub/grub-0.93.20030118.ebuild b/sys-apps/grub/grub-0.93.20030118.ebuild
index 2b646bf7f17b..2427df56a862 100644
--- a/sys-apps/grub/grub-0.93.20030118.ebuild
+++ b/sys-apps/grub/grub-0.93.20030118.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.93.20030118.ebuild,v 1.10 2003/07/27 18:46:41 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.93.20030118.ebuild,v 1.11 2003/09/06 16:27:42 pappy Exp $
inherit mount-boot eutils flag-o-matic
@@ -42,6 +42,13 @@ src_compile() {
use static && export LDFLAGS="${LDFLAGS} -static"
+ # http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
+ # grub configur somehow messes up the CFLAGS, so we need to do it dirty
+ # this is only activated when transparent hardened-gcc is found!
+ if has_version 'sys-devel/hardened-gcc' && [ ${CC}="gcc" ] ; then
+ CC="${CC} -yet_exec"
+ fi
+
econf --exec-prefix=/ \
--disable-auto-linux-mem-opt || die
emake || die