summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-20 22:03:25 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-20 22:03:25 +0000
commit50c1c14a8cd11f9f112357de57d6494d2a6d34ed (patch)
treef20682983c8cd30a2ed642b2aa7dc46efaf5d3a2 /sys-apps/fcron
parentInitial binary ebuild for OpenOffice (diff)
downloadhistorical-50c1c14a8cd11f9f112357de57d6494d2a6d34ed.tar.gz
historical-50c1c14a8cd11f9f112357de57d6494d2a6d34ed.tar.bz2
historical-50c1c14a8cd11f9f112357de57d6494d2a6d34ed.zip
New cronlayout. all the new releases are currently masked - please test. see also message on gentoo-dev
Diffstat (limited to 'sys-apps/fcron')
-rw-r--r--sys-apps/fcron/ChangeLog20
-rw-r--r--sys-apps/fcron/fcron-2.0.0-r1.ebuild83
-rw-r--r--sys-apps/fcron/files/crontab23
-rw-r--r--sys-apps/fcron/files/digest-fcron-2.0.0-r11
-rw-r--r--sys-apps/fcron/files/fcron-2.0.0-gentoo.diff22
-rw-r--r--sys-apps/fcron/files/fcron.conf24
-rw-r--r--sys-apps/fcron/files/fcron.rc630
7 files changed, 203 insertions, 0 deletions
diff --git a/sys-apps/fcron/ChangeLog b/sys-apps/fcron/ChangeLog
new file mode 100644
index 000000000000..8d3bc3de1dd4
--- /dev/null
+++ b/sys-apps/fcron/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for app-admin/fcron
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/ChangeLog,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/fcron.rc6 :
+
+ added "logger hostname" to need - "backport" from app-admin/fcron/files/fcron.rc6
+
+ 19 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/fcron.rc6 :
+
+ added "provide cron"
+
+ 19 Apr 2002; Thilo Bangert <bangert@gentoo.org> frcon-2.0.0-r1.ebuild :
+
+ added RDEPEND="!virtual/cron sys-apps/cronbase" and PROVIDE="virtual/cron"
+ changed spooldir to /var/spool/cron
+ added symlink for crontab
+ fixed html docs
+ installed default config with crontabs located in /var/spool/cron/crontabs \ No newline at end of file
diff --git a/sys-apps/fcron/fcron-2.0.0-r1.ebuild b/sys-apps/fcron/fcron-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..cece355dce48
--- /dev/null
+++ b/sys-apps/fcron/fcron-2.0.0-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry A! <jerry@gentoo.org>, Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/fcron-2.0.0-r1.ebuild,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
+HOMEPAGE="http://fcron.free.fr/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://fcron.free.fr/${P}.src.tar.gz"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="!virtual/cron
+ sys-apps/cronbase
+ virtual/mta"
+
+PROVIDE="virtual/cron"
+
+src_unpack() {
+
+ unpack ${A} ; cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die "bad patchfile"
+ autoconf || die "autoconf problem"
+}
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr \
+ --with-username=cron \
+ --with-groupname=cron \
+ --with-piddir=/var/run \
+ --with-etcdir=/etc/fcron \
+ --with-spooldir=/var/spool/cron \
+ --with-sendmail=/usr/sbin/sendmail \
+ --with-cflags="${CFLAGS}" --host=${CHOST} || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ diropts -m 770 -o cron -g cron
+ dodir /var/spool/cron/crontabs
+
+ insinto /usr/sbin
+ insopts -o root -g root -m 0110 ; doins fcron
+
+ insinto /usr/bin
+ insopts -o cron -g cron -m 6110 ; doins fcrontab
+ insopts -o root -g cron -m 6110 ; doins fcronsighup
+
+ dosym fcrontab /usr/bin/crontab
+
+ doman doc/*.{1,3,5,8}
+
+ dodoc MANIFEST VERSION doc/{CHANGES,README,LICENSE,FAQ,INSTALL,THANKS}
+ newdoc ${FILESDIR}/fcron.conf fcron.conf.sample
+ docinto html ; dohtml doc/*.html
+
+ insinto /etc/fcron
+ insopts -m 640 -o root -g cron
+ doins ${FILESDIR}/{fcron.allow,fcron.deny,fcron.conf}
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/fcron.rc6 fcron
+
+ insinto /etc
+ doins ${FILESDIR}/crontab
+
+ dodoc ${FILESDIR}/crontab
+}
+
+pkg_postinst() {
+
+ echo
+ einfo "To activate /etc/cron.{hourly|daily|weekly|montly} please run: "
+ einfo "crontab /etc/crontab"
+ echo
+ einfo "!!! That will replace root's current crontab !!!"
+ echo
+
+} \ No newline at end of file
diff --git a/sys-apps/fcron/files/crontab b/sys-apps/fcron/files/crontab
new file mode 100644
index 000000000000..bbeed56239ff
--- /dev/null
+++ b/sys-apps/fcron/files/crontab
@@ -0,0 +1,23 @@
+
+# /etc/crontab
+# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org>
+# $ Header: $
+
+# fcron || dcron:
+# This is NOT the system crontab! fcron and dcron do not support a system crontab.
+# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron or dcron do
+# crontab /etc/crontab
+# as root.
+# NOTE: This will REPLACE root's current crontab!!
+
+
+# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+
+*/15 * * * * /usr/bin/test -x /usr/sbin/run-crons && /usr/sbin/run-crons
+0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+0 0 * * * rm -f /var/spool/cron/lastrun/cron.daily
+0 0 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+0 0 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
+
+
+
diff --git a/sys-apps/fcron/files/digest-fcron-2.0.0-r1 b/sys-apps/fcron/files/digest-fcron-2.0.0-r1
new file mode 100644
index 000000000000..45d732101fce
--- /dev/null
+++ b/sys-apps/fcron/files/digest-fcron-2.0.0-r1
@@ -0,0 +1 @@
+MD5 b20c6bc5d9435a790e5500ecb7990df8 fcron-2.0.0.src.tar.gz 144069
diff --git a/sys-apps/fcron/files/fcron-2.0.0-gentoo.diff b/sys-apps/fcron/files/fcron-2.0.0-gentoo.diff
new file mode 100644
index 000000000000..aa6c0362f6e1
--- /dev/null
+++ b/sys-apps/fcron/files/fcron-2.0.0-gentoo.diff
@@ -0,0 +1,22 @@
+--- configure.in.orig Sun Jul 8 07:32:17 2001
++++ configure.in Sat Aug 25 14:36:05 2001
+@@ -201,13 +201,13 @@
+ fi
+ ;;
+ *)
+- if test -d "$withval"; then
++# if test -d "$withval"; then
+ etcdir="$withval"
+- AC_MSG_RESULT($withval)
+- else
+- AC_MSG_ERROR([
+-Directory $withval does not exist])
+- fi
++# AC_MSG_RESULT($withval)
++# else
++# AC_MSG_ERROR([
++#Directory $withval does not exist])
++# fi
+ ;;
+ esac ],
+ if test -d "/etc"; then
diff --git a/sys-apps/fcron/files/fcron.conf b/sys-apps/fcron/files/fcron.conf
new file mode 100644
index 000000000000..eb7e47af9d07
--- /dev/null
+++ b/sys-apps/fcron/files/fcron.conf
@@ -0,0 +1,24 @@
+# fcron.conf - Configuration file for fcron(8) and fcrontab(1).
+# See fcron.conf(5) for syntax and explanations.
+#
+# WARNING : this file must be owned by root:cron and 640.
+#
+# $ Header: $
+#
+
+# The spool directory where fcron stores its files
+fcrontabs = /var/spool/cron/crontabs
+
+# The location of the pidfile
+pidfile = /var/run/fcron.pid
+
+# allow/deny files to determine which users are allowed to use fcrontab
+fcronallow = /etc/fcron/fcron.allow
+fcrondeny = /etc/fcron/fcron.deny
+
+# Location of the programs used by fcron
+shell = /bin/sh
+sendmail = /usr/sbin/sendmail
+
+# Location of the default editor for "fcrontab -e"
+editor = /usr/bin/nano
diff --git a/sys-apps/fcron/files/fcron.rc6 b/sys-apps/fcron/files/fcron.rc6
new file mode 100644
index 000000000000..26dc4d68e431
--- /dev/null
+++ b/sys-apps/fcron/files/fcron.rc6
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/files/fcron.rc6,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+depend() {
+ need clock hostname logger
+ provide cron
+}
+
+checkconfig() {
+ if [ ! -e /etc/fcron/fcron.conf ] ; then
+ eerror "You will need an /etc/fcron/fcron.conf first"
+ eerror "There is a sample in /etc/fcron"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting fcron"
+ start-stop-daemon --start --quiet --exec /usr/sbin/fcron
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping fcron"
+ start-stop-daemon --stop --quiet --pidfile /var/run/fcron.pid
+ eend $?
+}