summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-10 18:50:04 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-10 18:50:04 +0000
commitebca99f45150154a43a705a5ef167326de5b1a62 (patch)
tree7e2a1a6f7d7dd31b9b6483618386e074ff88689a /sys-apps/dcron
parentchanged harcoded (diff)
downloadhistorical-ebca99f45150154a43a705a5ef167326de5b1a62.tar.gz
historical-ebca99f45150154a43a705a5ef167326de5b1a62.tar.bz2
historical-ebca99f45150154a43a705a5ef167326de5b1a62.zip
resolution for bug #87
Diffstat (limited to 'sys-apps/dcron')
-rw-r--r--sys-apps/dcron/dcron-2.7-r7.ebuild50
-rw-r--r--sys-apps/dcron/files/digest-dcron-2.7-r71
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/dcron/dcron-2.7-r7.ebuild b/sys-apps/dcron/dcron-2.7-r7.ebuild
new file mode 100644
index 000000000000..fc6a607335f6
--- /dev/null
+++ b/sys-apps/dcron/dcron-2.7-r7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7-r7.ebuild,v 1.1 2002/01/10 18:50:04 azarah Exp $
+
+# to use this, you must be part of the "cron" group
+
+S=${WORKDIR}/dcron
+DESCRIPTION="A cute little cron from Matt Dillon"
+SRC_URI="http://apollo.backplane.com/FreeSrc/dcron27.tgz"
+HOMEPAGE="http://apollo.backplane.com"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff || die
+ # fix 'crontab -e' to look at $EDITOR and not $VISUAL
+ cp ${S}/crontab.c ${S}/crontab.c.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.c.orig > ${S}/crontab.c
+ cp ${S}/crontab.1 ${S}/crontab.1.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.1.orig > ${S}/crontab.1
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ # lets just do it this way shall we
+ dodir /usr/{sbin,bin}
+ install -o root -g wheel -m 0700 crond ${D}/usr/sbin
+ install -o root -g cron -m 4750 crontab ${D}/usr/bin
+
+ diropts -m0755 ; dodir /var
+ diropts -m0750 ; dodir /var/cron/lastrun
+ # gotcha: /var/spool needs to be 755
+ diropts -m0755 ; dodir /var/spool
+ diropts -m0750 ; dodir /var/spool/cron/crontabs
+ # this still do not alway get created
+ touch ${D}/var/spool/cron/crontabs/.dummy
+
+ dodoc CHANGELOG README
+ doman crontab.1 crond.8
+
+ insinto /etc ; doins ${FILESDIR}/crontab
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dcron.rc6 dcron
+}
diff --git a/sys-apps/dcron/files/digest-dcron-2.7-r7 b/sys-apps/dcron/files/digest-dcron-2.7-r7
new file mode 100644
index 000000000000..ca4a83b2719e
--- /dev/null
+++ b/sys-apps/dcron/files/digest-dcron-2.7-r7
@@ -0,0 +1 @@
+MD5 8984a6bb120cd674d4fb7f1cc52630a2 dcron27.tgz 16384