summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-11 22:38:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-11 22:38:25 +0000
commita7b34376d0747edb22745e1ae1db69620b92ca77 (patch)
tree0207b17ac5d78b27688657dc050778a2dc207f2a /skel.ebuild
parentversion bump (diff)
downloadhistorical-a7b34376d0747edb22745e1ae1db69620b92ca77.tar.gz
historical-a7b34376d0747edb22745e1ae1db69620b92ca77.tar.bz2
historical-a7b34376d0747edb22745e1ae1db69620b92ca77.zip
Add note about not putting S=${WORKDIR}/${P} in ebuilds.
Add mention of using -j1 for buggy makefiles and why.
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/skel.ebuild b/skel.ebuild
index 8f8fe3970d18..ce262a9c5ea1 100644
--- a/skel.ebuild
+++ b/skel.ebuild
@@ -77,8 +77,9 @@ DEPEND=""
#RDEPEND=""
# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
-# if you omit this line.
+# unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
+# If you don't need to change it, leave the S= line out of the ebuild
+# to keep it tidy.
S=${WORKDIR}/${P}
src_compile() {
@@ -102,16 +103,17 @@ src_compile() {
# portage shortcut to the above ./configure statement:
#
# econf || die
- # Note that econf will die on failure, but plase use econf || die
+ # Note that econf will die on failure, but please use econf || die
# for consistency.
# emake (previously known as pmake) is a script that calls the
# standard GNU make with parallel building options for speedier
# builds (especially on SMP systems). Try emake first. It might
- # not work for some packages, in which case you'll have to resort
- # to normal "make".
- emake || die
- #make || die
+ # not work for some packages, because some makefiles have bugs
+ # related to parallelism, in these cases, use emake -j1 to limit
+ # make to a single process. The -j1 is a visual clue to others
+ # that the makefiles have bugs that have been worked around.
+ emake || die "emake failed"
}
src_install() {