summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-08-23 10:49:12 +0000
committerSven Vermeulen <swift@gentoo.org>2014-08-23 10:49:12 +0000
commit124abe0befb75958dbcb310f8857b3c9c11bfc2d (patch)
treec318a7e8e994284bc859ad2fd8c8d0211b109eb7 /sec-policy/selinux-base-policy
parentRelabel depending packages so we no longer need DEPEND calls for pure policy ... (diff)
downloadhistorical-124abe0befb75958dbcb310f8857b3c9c11bfc2d.tar.gz
historical-124abe0befb75958dbcb310f8857b3c9c11bfc2d.tar.bz2
historical-124abe0befb75958dbcb310f8857b3c9c11bfc2d.zip
Enable package relabeling for selinux-base-policy
Diffstat (limited to 'sec-policy/selinux-base-policy')
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
index 50a556548f0d..b56bd725d1d9 100644
--- a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild,v 1.10 2014/08/09 19:34:19 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild,v 1.11 2014/08/23 10:49:12 swift Exp $
EAPI="5"
inherit eutils
@@ -131,4 +131,16 @@ pkg_postinst() {
semodule -s ${i} -b base.pp ${COMMAND} || die "Failed to load in base and modules ${MODS} in the $i policy store"
done
+
+ # Relabel depending packages
+ PKGSET="";
+ if [ -x /usr/bin/qdepends ] ; then
+ PKGSET=$(/usr/bin/qdepends -Cq -Q ${CATEGORY}/${PN});
+ elif [ -x /usr/bin/equery ] ; then
+ PKGSET=$(/usr/bin/equery -Cq depends ${CATEGORY}/${PN});
+ fi
+ for PKG in ${PKGSET};
+ do
+ rlpkg ${PKG};
+ done
}