summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-12-09 12:28:36 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-12-09 12:28:36 +0000
commitf51c96cf577b4dd51950c60a04dc6fe1ae5be3fa (patch)
tree0200db3567e9cf2f05f9072b0636cd14aa7f71bf /sci-physics/xfoil/xfoil-6.97.ebuild
parentVersion bump (diff)
downloadhistorical-f51c96cf577b4dd51950c60a04dc6fe1ae5be3fa.tar.gz
historical-f51c96cf577b4dd51950c60a04dc6fe1ae5be3fa.tar.bz2
historical-f51c96cf577b4dd51950c60a04dc6fe1ae5be3fa.zip
Added LDFLAGS propagation
Package-Manager: portage-2.2_rc17/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'sci-physics/xfoil/xfoil-6.97.ebuild')
-rw-r--r--sci-physics/xfoil/xfoil-6.97.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-physics/xfoil/xfoil-6.97.ebuild b/sci-physics/xfoil/xfoil-6.97.ebuild
index 075a209a13e6..b8696fe60de6 100644
--- a/sci-physics/xfoil/xfoil-6.97.ebuild
+++ b/sci-physics/xfoil/xfoil-6.97.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/xfoil-6.97.ebuild,v 1.2 2008/08/23 11:43:27 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/xfoil-6.97.ebuild,v 1.3 2008/12/09 12:28:36 bicatali Exp $
inherit eutils fortran
@@ -28,7 +28,7 @@ src_unpack() {
-e '/^FFLAGS/d' \
-e '/^CFLAGS/d' \
-e 's/^\(FFLOPT .*\)/FFLOPT = $(FFLAGS)/g' \
- bin/Makefile plotlib/Makefile plotlib/config.make orrs/bin/Makefile \
+ {bin,plotlib,orrs/bin}/Makefile plotlib/config.make \
|| die "sed for flags and compilers failed"
# fix bug #147033
@@ -43,7 +43,7 @@ src_unpack() {
src_compile() {
export FC="${FORTRANC}" F77="${FORTRANC}"
cd "${S}"/orrs/bin
- emake FLG="${FFLAGS}" FTNLIB="" OS || die "failed to build orrs"
+ emake FLG="${FFLAGS}" FTNLIB="${LDFLAGS}" OS || die "failed to build orrs"
cd "${S}"/orrs
bin/osgen osmaps_ns.lst
cd "${S}"/plotlib
@@ -53,6 +53,7 @@ src_compile() {
emake \
PLTOBJ="../plotlib/libPlt.a" \
CFLAGS="${CFLAGS} -DUNDERSCORE" \
+ FTNLIB="${LDFLAGS}" \
${i} || die "failed to build ${i}"
done
}