summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-02 17:46:05 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-02 17:46:05 +0000
commit800d786d41052ea138832eb4ea158f218bb678f8 (patch)
tree33afd0008b19c2289ff69b3c85b25e2207e2b3ac /sci-mathematics
parentDon't set host to avoid bad interaction with pam_ck_connector.so from sys-aut... (diff)
downloadhistorical-800d786d41052ea138832eb4ea158f218bb678f8.tar.gz
historical-800d786d41052ea138832eb4ea158f218bb678f8.tar.bz2
historical-800d786d41052ea138832eb4ea158f218bb678f8.zip
Addition requested #347577
Package-Manager: portage-2.2.0_alpha6/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/ent/ChangeLog10
-rw-r--r--sci-mathematics/ent/Manifest15
-rw-r--r--sci-mathematics/ent/ent-101202.ebuild26
-rw-r--r--sci-mathematics/ent/files/101202-gentoo.patch20
-rw-r--r--sci-mathematics/ent/metadata.xml8
5 files changed, 79 insertions, 0 deletions
diff --git a/sci-mathematics/ent/ChangeLog b/sci-mathematics/ent/ChangeLog
new file mode 100644
index 000000000000..729526332c42
--- /dev/null
+++ b/sci-mathematics/ent/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/ent
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ent/ChangeLog,v 1.1 2010/12/02 17:46:05 jlec Exp $
+
+*ent-101202 (02 Dec 2010)
+
+ 02 Dec 2010; Justin Lecher <jlec@gentoo.org> +files/101202-gentoo.patch,
+ +ent-101202.ebuild, +metadata.xml:
+ Addition requested #347577
+
diff --git a/sci-mathematics/ent/Manifest b/sci-mathematics/ent/Manifest
new file mode 100644
index 000000000000..21dcd2e82c13
--- /dev/null
+++ b/sci-mathematics/ent/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX 101202-gentoo.patch 448 RMD160 f552dbdf1ca767f41f78160864608a34f639e985 SHA1 040266835da23dac0f50db3e065388ad2d7adb53 SHA256 03e84206b47757dbfaf98d455e6b831f856d6694f7c46eefee93001c2ad57570
+DIST random-101202.zip 76200 RMD160 b21b8401fdbd2aac189fe4a442a1164b172407f8 SHA1 0f2f12dc67d1f02f77776709cf5fc5eee1d1b2e2 SHA256 c14ed62db24511848d6b37d4bf8869185b65be9042ffad5272257f3a249569ec
+EBUILD ent-101202.ebuild 636 RMD160 7f6aa8117b5ee435d304d79688a084ecfbbb188c SHA1 8187b94dfc4cb4a56794e7457957d4174cd89b07 SHA256 86ab0bec1d8233164640ea9f22741d2f7f064d89056c12e7943ac49de4903048
+MISC ChangeLog 378 RMD160 e80eaacd24562e90be9cd9f630607f3d33361e55 SHA1 0f485c50a191609f7ffc53ea32dbb8aa84bffe8a SHA256 838ea629e5e5ccba6fedd9c01e74833ef365b54693577b9a7f3b161f9b0458f1
+MISC metadata.xml 228 RMD160 53f884e50dcf18aa88d00151132632b92b1e13b1 SHA1 1fd6e982961ada0ccca1e3a6c2aab18c737d3042 SHA256 3b9c7cbdeda544f3a9eca6e4a8df5070d738dd8acd0bfa8eec36f0517312b7e2
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAkz322IACgkQgAnW8HDreRYg6gCgo4Ri91OU6k2JcC7bGcjGlHdy
++MQAn28Y/SxfHSnXsfamYdYKvFdUekRo
+=9S9q
+-----END PGP SIGNATURE-----
diff --git a/sci-mathematics/ent/ent-101202.ebuild b/sci-mathematics/ent/ent-101202.ebuild
new file mode 100644
index 000000000000..5fa5278422db
--- /dev/null
+++ b/sci-mathematics/ent/ent-101202.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ent/ent-101202.ebuild,v 1.1 2010/12/02 17:46:05 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Pseudorandom number sequence test"
+HOMEPAGE="http://www.fourmilab.ch/random/"
+SRC_URI="mirror://gentoo/random-${PV}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="public-domain"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN} || die
+ dohtml ${PN}.html ${PN}itle.gif || die
+}
diff --git a/sci-mathematics/ent/files/101202-gentoo.patch b/sci-mathematics/ent/files/101202-gentoo.patch
new file mode 100644
index 000000000000..a71bc5050637
--- /dev/null
+++ b/sci-mathematics/ent/files/101202-gentoo.patch
@@ -0,0 +1,20 @@
+diff --git a/Makefile b/Makefile
+index 2a150cf..3f9b883 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,12 +1,12 @@
+
+ # Unix make file for random test program
+
+-CC = gcc
+-CFLAGS = -g -Wall
++CC ?= gcc
++CFLAGS ?= -g -Wall
+ #CFLAGS = -O
+
+ ent: ent.o iso8859.o randtest.o chisq.o
+- $(CC) $(CFLAGS) ent.o iso8859.o randtest.o chisq.o -o ent -lm
++ $(CC) $(LDFLAGS) $(CFLAGS) ent.o iso8859.o randtest.o chisq.o -o ent -lm
+
+ ent.c: iso8859.h randtest.h
+
diff --git a/sci-mathematics/ent/metadata.xml b/sci-mathematics/ent/metadata.xml
new file mode 100644
index 000000000000..a2070de023f7
--- /dev/null
+++ b/sci-mathematics/ent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>