summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-06-20 10:58:09 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-06-20 10:58:09 +0000
commit1bc1f7247232d5ccc966baa849db2a856729e5e5 (patch)
tree75fcc7c04e595c7842cbb1a0fb80c3470c2fb00e /sci-libs
parentVersion bump (diff)
downloadhistorical-1bc1f7247232d5ccc966baa849db2a856729e5e5.tar.gz
historical-1bc1f7247232d5ccc966baa849db2a856729e5e5.tar.bz2
historical-1bc1f7247232d5ccc966baa849db2a856729e5e5.zip
initial commit, bug 225287
Package-Manager: portage-2.1.6.13/cvs/Linux ppc
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/plotmm/ChangeLog11
-rw-r--r--sci-libs/plotmm/Manifest5
-rw-r--r--sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch100
-rw-r--r--sci-libs/plotmm/metadata.xml10
-rw-r--r--sci-libs/plotmm/plotmm-0.1.2.ebuild62
5 files changed, 188 insertions, 0 deletions
diff --git a/sci-libs/plotmm/ChangeLog b/sci-libs/plotmm/ChangeLog
new file mode 100644
index 000000000000..2b989103e6da
--- /dev/null
+++ b/sci-libs/plotmm/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/plotmm
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/plotmm/ChangeLog,v 1.1 2009/06/20 10:58:09 volkmar Exp $
+
+*plotmm-0.1.2 (20 Jun 2009)
+
+ 20 Jun 2009; Mounir Lamouri <volkmar@gentoo.org>
+ +files/plotmm-0.1.2-libsigc++-2.2.patch, +metadata.xml,
+ +plotmm-0.1.2.ebuild:
+ Initial commit. Fix bug 225287.
+
diff --git a/sci-libs/plotmm/Manifest b/sci-libs/plotmm/Manifest
new file mode 100644
index 000000000000..2e4ea43e27d0
--- /dev/null
+++ b/sci-libs/plotmm/Manifest
@@ -0,0 +1,5 @@
+AUX plotmm-0.1.2-libsigc++-2.2.patch 4037 RMD160 21266c4274d42e3da0957f07ae3dfb566fc9f4fd SHA1 d54faf2882060a317b0c2dc6c6395050204f3951 SHA256 6c535a0665d561841dc1fa9fce29eb18735850bea3d7af8b19e1d20050237cc6
+DIST plotmm-0.1.2.tar.gz 473175 RMD160 1a42a6681f540911c58a23290e1f7f9877bc49c1 SHA1 64da0930b7c8994d59769597917cca05df989258 SHA256 896bb729eb9cad5f3188d72304789dd7a86fdae66020ac0632fe3bc66abe9653
+EBUILD plotmm-0.1.2.ebuild 1605 RMD160 3ff4b332c31291434dfe270e2eddaefcb75a4030 SHA1 c828f332226d5247b60aefa3a3f3884f5cbd4d40 SHA256 298c25a8cdd356e91af99824bd742f359fce7a83b66fc3df162c190406a3908b
+MISC ChangeLog 401 RMD160 9333c43fd64edc381d38d3fd1911ee514e424644 SHA1 3793b67080be58e6dc9384854193e8dd327411cf SHA256 8a19ef8ee7ebd3842da1102512b3dfeb5ba5cfaa4529c0c16e96ad59e2d452b3
+MISC metadata.xml 257 RMD160 224ee82bfe66c5da4a2dc1dd697b1782e7f03cb9 SHA1 6b583c76750b206bd133403d1a4685a14f8e6b95 SHA256 45f231de4d8bc5ed6309ba83d2eb9a06b8e13f828d7b74e909a144439356cd62
diff --git a/sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch b/sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch
new file mode 100644
index 000000000000..a9aa53190d5f
--- /dev/null
+++ b/sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch
@@ -0,0 +1,100 @@
+diff -ur plotmm-0.1.2-old/plotmm/compat.h plotmm-0.1.2/plotmm/compat.h
+--- plotmm-0.1.2-old/plotmm/compat.h 2005-11-09 17:36:02.000000000 +0100
++++ plotmm-0.1.2/plotmm/compat.h 2008-07-25 00:13:55.000000000 +0200
+@@ -58,7 +58,7 @@
+ #else
+
+ namespace PlotMM {
+- typedef SigC::ObjectBase ObjectBase;
++ typedef sigc::ObjectBase ObjectBase;
+ }
+
+ #endif
+diff -ur plotmm-0.1.2-old/plotmm/curve.h plotmm-0.1.2/plotmm/curve.h
+--- plotmm-0.1.2-old/plotmm/curve.h 2005-11-09 17:47:21.000000000 +0100
++++ plotmm-0.1.2/plotmm/curve.h 2008-07-25 00:24:02.000000000 +0200
+@@ -140,7 +140,7 @@
+ int from = 0, int to = -1);
+
+ //! Signals that this curve has changed in some way or the other
+- SigC::Signal0<void> signal_curve_changed;
++ sigc::signal0<void> signal_curve_changed;
+
+ protected:
+ virtual void init(const Glib::ustring &title);
+diff -ur plotmm-0.1.2-old/plotmm/plot.cc plotmm-0.1.2/plotmm/plot.cc
+--- plotmm-0.1.2-old/plotmm/plot.cc 2005-11-09 17:59:48.000000000 +0100
++++ plotmm-0.1.2/plotmm/plot.cc 2008-07-25 00:24:30.000000000 +0200
+@@ -322,7 +322,7 @@
+ connect(sigc::mem_fun(*this,&Plot::on_canvas_expose_event));
+ #else
+ canvas_.signal_expose_event().
+- connect(SigC::slot(*this,&Plot::on_canvas_expose_event));
++ connect(sigc::slot(*this,&Plot::on_canvas_expose_event));
+ #endif
+
+ show_all();
+@@ -406,19 +406,19 @@
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
++sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
+ {
+ return canvas_.signal_plot_mouse_press;
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
++sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
+ {
+ return canvas_.signal_plot_mouse_release;
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
++sigc::signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
+ {
+ return canvas_.signal_plot_mouse_move;
+ }
+diff -ur plotmm-0.1.2-old/plotmm/plot.h plotmm-0.1.2/plotmm/plot.h
+--- plotmm-0.1.2-old/plotmm/plot.h 2004-03-09 10:51:55.000000000 +0100
++++ plotmm-0.1.2/plotmm/plot.h 2008-07-25 00:25:17.000000000 +0200
+@@ -79,9 +79,9 @@
+ virtual void clear();
+ virtual void end_replot();
+
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
+- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
++ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
+
+ protected:
+ virtual bool on_expose_event(GdkEventExpose* event);
+@@ -141,9 +141,9 @@
+ Scale *scale(PlotAxisID id) { return tickMark_[id]; }
+ PlotLabel *label(PlotAxisID id) { return axisLabel_[id]; }
+
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
+- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
++ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
+
+ void set_selection(const Rectangle &r);
+ Rectangle get_selection() { return select_; }
+diff -ur plotmm-0.1.2-old/plotmm/scale.h plotmm-0.1.2/plotmm/scale.h
+--- plotmm-0.1.2-old/plotmm/scale.h 2004-03-05 16:25:43.000000000 +0100
++++ plotmm-0.1.2/plotmm/scale.h 2008-07-25 00:25:30.000000000 +0200
+@@ -133,7 +133,7 @@
+ /*! This signal is thrown whenever the scale is enabled or disabled
+ * \sa set_enabled, enabled
+ */
+- SigC::Signal1<void,bool> signal_enabled;
++ sigc::signal1<void,bool> signal_enabled;
+
+ protected:
+ virtual void on_realize();
diff --git a/sci-libs/plotmm/metadata.xml b/sci-libs/plotmm/metadata.xml
new file mode 100644
index 000000000000..d44dc8ef07cc
--- /dev/null
+++ b/sci-libs/plotmm/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>volkmar@gentoo.org</email>
+ <name>Mounir Lamouri</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/sci-libs/plotmm/plotmm-0.1.2.ebuild b/sci-libs/plotmm/plotmm-0.1.2.ebuild
new file mode 100644
index 000000000000..29086fee00d3
--- /dev/null
+++ b/sci-libs/plotmm/plotmm-0.1.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/plotmm/plotmm-0.1.2.ebuild,v 1.1 2009/06/20 10:58:09 volkmar Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Plot widget for GTKmm"
+HOMEPAGE="http://plotmm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND="|| ( dev-cpp/gtkmm:2.4 dev-cpp/gtkmm:2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+# NOTES:
+# somewhat, there is a dep on libsigc++ but it's much more via gtkmm
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-libsigc++-2.2.patch"
+
+ if ! use examples; then
+ sed -i -e "s:examples::" Makefile.in || die "sed failed"
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-libtool-lock
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r doc/html/* || die "dohtml failed"
+ fi
+
+ if use examples; then
+ # rename installed bin files
+ mv "${D}"/usr/bin/curves "${D}"/usr/bin/${PN}-curves || die "mv failed"
+ mv "${D}"/usr/bin/simple "${D}"/usr/bin/${PN}-simple || die "mv failed"
+
+ # install sources
+ insinto /usr/share/doc/${PF}/examples/
+ doins examples/{curves/curves,simple/simple}.cc || die "doins failed"
+
+ elog "You can use examples by calling ${PN}-curves or ${PN}-simple."
+ elog "Examples source code is in /usr/share/doc/${PF}/examples."
+ fi
+}