summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-05-09 11:21:27 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-05-09 11:21:27 +0000
commit4b1e1387b55c8c997c57de4943a4a2c39af31887 (patch)
tree315b486202eac8daaea499da82e506290faed555 /sci-libs/torch
parentPruned old ebuilds, changed describtion. (diff)
downloadhistorical-4b1e1387b55c8c997c57de4943a4a2c39af31887.tar.gz
historical-4b1e1387b55c8c997c57de4943a4a2c39af31887.tar.bz2
historical-4b1e1387b55c8c997c57de4943a4a2c39af31887.zip
Don't add -malign-double on amd64, keyworded ~amd64.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'sci-libs/torch')
-rw-r--r--sci-libs/torch/ChangeLog7
-rw-r--r--sci-libs/torch/Manifest12
-rw-r--r--sci-libs/torch/torch-3.ebuild14
3 files changed, 19 insertions, 14 deletions
diff --git a/sci-libs/torch/ChangeLog b/sci-libs/torch/ChangeLog
index 0461589f94aa..ec37bd671686 100644
--- a/sci-libs/torch/ChangeLog
+++ b/sci-libs/torch/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/torch
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/ChangeLog,v 1.2 2004/12/29 10:10:59 swegener Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/ChangeLog,v 1.3 2005/05/09 11:21:27 herbs Exp $
+
+ 09 May 2005; Herbie Hopkins <herbs@gentoo.org> torch-3.ebuild:
+ Don't add -malign-double on amd64, keyworded ~amd64.
*torch-3 (28 Dec 2004)
diff --git a/sci-libs/torch/Manifest b/sci-libs/torch/Manifest
index dd8606895a13..a8e6846a74d6 100644
--- a/sci-libs/torch/Manifest
+++ b/sci-libs/torch/Manifest
@@ -1,14 +1,14 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 2f0660761deb097e79387ace1d5b0346 ChangeLog 597
-MD5 e9b62c17ec2d94d1639353563f5b9183 torch-3.ebuild 1933
+MD5 ab172512457f80c602c11b65765fd905 ChangeLog 715
+MD5 b3c4e2abffde512a8f3700aee14bbb1a torch-3.ebuild 2047
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 b783f0f266b5452761370caf0b78e7f3 files/digest-torch-3 117
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
+Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFB0oK5I1lqEGTUzyQRAlknAKDSYrgMhwJf/E8hzUNBCwQ4hzWT6gCgrJRC
-sjzhrmiYTpqwbL+eeY7rQg8=
-=PjzA
+iD8DBQFCf0fM2G5bA0cA/ScRAmGRAJ9YG2pMHC8bk98vllo48OCg4pTMpACfaWzn
+dxlUeVPmXrZ9SU//eyg18xU=
+=s0mX
-----END PGP SIGNATURE-----
diff --git a/sci-libs/torch/torch-3.ebuild b/sci-libs/torch/torch-3.ebuild
index 7266834846b9..582425824a99 100644
--- a/sci-libs/torch/torch-3.ebuild
+++ b/sci-libs/torch/torch-3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/torch-3.ebuild,v 1.1 2004/12/29 00:44:27 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/torch-3.ebuild,v 1.2 2005/05/09 11:21:27 herbs Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs multilib
DESCRIPTION="machine-learning library, written in simple C++"
HOMEPAGE="http://www.torch.ch/"
@@ -11,7 +11,7 @@ SRC_URI="http://www.torch.ch/archives/Torch${PV}src.tgz
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
IUSE="doc debug"
DEPEND="virtual/libc"
@@ -23,11 +23,13 @@ torch_packages="convolutions datasets decoder distributions gradients kernels ma
src_compile() {
local shalldebug="OPT"
use debug && shalldebug="DBG"
+ # -malign-double makes no sense on a 64-bit arch
+ use amd64 || extraflags="-malign-double"
cp config/Makefile_options_Linux .
sed -i \
-e "s:^PACKAGES.*:PACKAGES = ${torch_packages}:" \
-e "s:^DEBUG.*:DEBUG = ${shalldebug}:" \
- -e "s:^CFLAGS_OPT_FLOAT.*:CFLAGS_OPT_FLOAT = -Wall ${CFLAGS} -ffast-math -malign-double:" \
+ -e "s:^CFLAGS_OPT_FLOAT.*:CFLAGS_OPT_FLOAT = -Wall ${CFLAGS} -ffast-math ${extraflags}:" \
Makefile_options_Linux
make depend
@@ -43,7 +45,7 @@ src_install() {
done
# prepare the options Makefile
sed -i \
- -e 's:^LIBS_DIR.*:LIBS_DIR=/usr/lib:' \
+ -e "s:^LIBS_DIR.*:LIBS_DIR=/usr/$(get_libdir):" \
-e 's|^INCS := .*|INCS := -I /usr/include/torch $(MYINCS)|' \
-e '/^INCS +=/c\' \
Makefile_options_Linux