summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2005-07-21 04:03:24 +0000
committerSteve Arnold <nerdboy@gentoo.org>2005-07-21 04:03:24 +0000
commit839001043002fa24559ca6e8d16326f846fa95ae (patch)
tree80600e93f9cd842263847a8b6ea1dd959b699677 /sci-libs/ogdi
parentversion bump, ebuild cleanup, and correction of my email address in the Chang... (diff)
downloadhistorical-839001043002fa24559ca6e8d16326f846fa95ae.tar.gz
historical-839001043002fa24559ca6e8d16326f846fa95ae.tar.bz2
historical-839001043002fa24559ca6e8d16326f846fa95ae.zip
fixed some build errors revealed by the new toolchain
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sci-libs/ogdi')
-rw-r--r--sci-libs/ogdi/ChangeLog8
-rw-r--r--sci-libs/ogdi/Manifest4
-rw-r--r--sci-libs/ogdi/files/digest-ogdi-3.1.4-r11
-rw-r--r--sci-libs/ogdi/ogdi-3.1.4-r1.ebuild33
4 files changed, 44 insertions, 2 deletions
diff --git a/sci-libs/ogdi/ChangeLog b/sci-libs/ogdi/ChangeLog
index b767a99ec846..80bdf335c41f 100644
--- a/sci-libs/ogdi/ChangeLog
+++ b/sci-libs/ogdi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/ogdi
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ogdi/ChangeLog,v 1.9 2005/07/11 19:15:35 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ogdi/ChangeLog,v 1.10 2005/07/21 04:03:24 nerdboy Exp $
+
+*ogdi-3.1.4-r1 (21 Jul 2005)
+
+ 21 Jul 2005; Steve Arnold <nerdboy@gentoo.org> +ogdi-3.1.4-r1.ebuild:
+ fixed some build errors revealed by the new toolchain -
+ TARGET not set properly and internal proj borkage
11 Jul 2005; Tobias Scherbaum <dertobi123@gentoo.org> ogdi-3.1.4.ebuild:
ppc stable, #98593
diff --git a/sci-libs/ogdi/Manifest b/sci-libs/ogdi/Manifest
index f8b1158e3f32..c23aa64c4bf7 100644
--- a/sci-libs/ogdi/Manifest
+++ b/sci-libs/ogdi/Manifest
@@ -1,6 +1,8 @@
-MD5 e114c614dee8fee2c4f5460a1ea421b1 ChangeLog 1607
+MD5 86b68ebda120ee52433e6822458c8a6c ChangeLog 1820
MD5 3cd06cd3d8efbe532cd128301ca23678 metadata.xml 219
MD5 e91a0bb37210e9b3f94852251dc0d8b5 ogdi-3.1.1.ebuild 1293
MD5 ee07060e76e4c9b834bd499530a306d4 ogdi-3.1.4.ebuild 1111
+MD5 d77921b50f401ab791420e7de59784dd ogdi-3.1.4-r1.ebuild 949
MD5 59e695f13d9d346bdd13a22bde58a3a6 files/digest-ogdi-3.1.1 62
MD5 e328cdec7e54dc60be77116181727d5a files/digest-ogdi-3.1.4 62
+MD5 e328cdec7e54dc60be77116181727d5a files/digest-ogdi-3.1.4-r1 62
diff --git a/sci-libs/ogdi/files/digest-ogdi-3.1.4-r1 b/sci-libs/ogdi/files/digest-ogdi-3.1.4-r1
new file mode 100644
index 000000000000..d587554ee978
--- /dev/null
+++ b/sci-libs/ogdi/files/digest-ogdi-3.1.4-r1
@@ -0,0 +1 @@
+MD5 d54a5dcce211e37b8ba317531312ff55 ogdi-3.1.4.tar.gz 912849
diff --git a/sci-libs/ogdi/ogdi-3.1.4-r1.ebuild b/sci-libs/ogdi/ogdi-3.1.4-r1.ebuild
new file mode 100644
index 000000000000..13bc3de22fb5
--- /dev/null
+++ b/sci-libs/ogdi/ogdi-3.1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ogdi/ogdi-3.1.4-r1.ebuild,v 1.1 2005/07/21 04:03:24 nerdboy Exp $
+
+DESCRIPTION="open geographical datastore interface"
+HOMEPAGE="http://ogdi.sourceforge.net"
+SRC_URI="mirror://sourceforge/ogdi/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sci-libs/proj
+ sys-libs/zlib
+ dev-libs/expat"
+
+src_compile() {
+ export TOPDIR="${S}"
+ export TARGET=`uname`
+ export CFG="release"
+ export LD_LIBRARY_PATH=$TOPDIR/bin/${TARGET}
+
+ econf --with-proj=/usr --with-projlib="-L/usr/lib -lproj" \
+ --with-zlib --with-expat || die "econf failed"
+ make || die "make failed"
+}
+
+src_install() {
+ einstall TARGET=`uname` TOPDIR="${S}" \
+ LD_LIBRARY_PATH="${TOPDIR}/bin/${TARGET}" || die "einstall failed"
+ dodoc ChangeLog LICENSE NEWS README VERSION
+}