summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-01-05 16:18:55 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-01-05 16:18:55 +0000
commitd585a757b2d1532ca434c37fe6bb9bec3a0c687f (patch)
tree4c7bd1ac51627d2f7dcce8b7d79c29e4b08e1164 /sci-libs/lapack
parentForgot about Manifest (diff)
downloadhistorical-d585a757b2d1532ca434c37fe6bb9bec3a0c687f.tar.gz
historical-d585a757b2d1532ca434c37fe6bb9bec3a0c687f.tar.bz2
historical-d585a757b2d1532ca434c37fe6bb9bec3a0c687f.zip
fixing #75298
Diffstat (limited to 'sci-libs/lapack')
-rw-r--r--sci-libs/lapack/ChangeLog8
-rw-r--r--sci-libs/lapack/Manifest16
-rw-r--r--sci-libs/lapack/lapack-3.0-r1.ebuild8
-rw-r--r--sci-libs/lapack/lapack-3.0.ebuild8
4 files changed, 17 insertions, 23 deletions
diff --git a/sci-libs/lapack/ChangeLog b/sci-libs/lapack/ChangeLog
index f4eef737294a..caadc96dbd6b 100644
--- a/sci-libs/lapack/ChangeLog
+++ b/sci-libs/lapack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/lapack
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack/ChangeLog,v 1.2 2004/12/29 21:55:10 swegener Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack/ChangeLog,v 1.3 2005/01/05 16:18:55 phosphan Exp $
+
+ 05 Jan 2005; Patrick Kursawe <phosphan@gentoo.org> lapack-3.0-r1.ebuild,
+ lapack-3.0.ebuild:
+ adding || die where necessary (bug #75298)
*lapack-3.0 (29 Dec 2004)
diff --git a/sci-libs/lapack/Manifest b/sci-libs/lapack/Manifest
index b18961959921..349002538da4 100644
--- a/sci-libs/lapack/Manifest
+++ b/sci-libs/lapack/Manifest
@@ -1,17 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 8dfc5521a5bcda108e28732bd1685b64 lapack-3.0-r1.ebuild 833
-MD5 6c18080f909061048af67cf62903e089 lapack-3.0.ebuild 730
-MD5 e554431e78983c905bf98980ea3215c9 ChangeLog 1207
+MD5 7e837898eb0a3c6146c8e84f31adc969 lapack-3.0-r1.ebuild 876
+MD5 c759fc8a271bc7903c709f5a02f9b5cb lapack-3.0.ebuild 773
+MD5 b9ec9392345c82790e76ea1015b4b5b9 ChangeLog 1349
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 823864ca423f83efce8f2b0b64bb44d6 files/Makefile 12334
MD5 dc3f9270e78caa228b1591e03109ef05 files/digest-lapack-3.0 56
MD5 dc3f9270e78caa228b1591e03109ef05 files/digest-lapack-3.0-r1 56
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFB0yfEI1lqEGTUzyQRAjiKAJ4w6tk64w5uu74pbEk81W/Kz2Aa8ACfbJbG
-tXUTL09BXVrt2PUVr9AMAQI=
-=OxmR
------END PGP SIGNATURE-----
diff --git a/sci-libs/lapack/lapack-3.0-r1.ebuild b/sci-libs/lapack/lapack-3.0-r1.ebuild
index d23b734c77ac..00dbf969a5a5 100644
--- a/sci-libs/lapack/lapack-3.0-r1.ebuild
+++ b/sci-libs/lapack/lapack-3.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack/lapack-3.0-r1.ebuild,v 1.2 2004/12/29 16:34:03 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack/lapack-3.0-r1.ebuild,v 1.3 2005/01/05 16:18:55 phosphan Exp $
DESCRIPTION="Linear Algebra PACKage for scientists, engineers, and mathematicians. This contains the libraries for creating programs that use LAPACK."
HOMEPAGE="http://www.netlib.org/lapack/"
@@ -21,9 +21,9 @@ src_compile() {
cd SRC
# ncessary to be able to link against liblapack.a on amd64
use amd64 && CFLAGS="${CFLAGS} -fPIC"
- FC="g77" FFLAGS="${CFLAGS}" make static
+ FC="g77" FFLAGS="${CFLAGS}" make static || die "make failed"
}
src_install() {
- dolib.a SRC/liblapack.a
+ dolib.a SRC/liblapack.a || die "dolib failed"
}
diff --git a/sci-libs/lapack/lapack-3.0.ebuild b/sci-libs/lapack/lapack-3.0.ebuild
index 1a172b0c5332..d595d4f7cfc6 100644
--- a/sci-libs/lapack/lapack-3.0.ebuild
+++ b/sci-libs/lapack/lapack-3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack/lapack-3.0.ebuild,v 1.2 2004/12/29 16:34:03 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack/lapack-3.0.ebuild,v 1.3 2005/01/05 16:18:55 phosphan Exp $
DESCRIPTION="Linear Algebra PACKage for scientists, engineers, and mathematicians. This contains the libraries for creating programs that use LAPACK."
HOMEPAGE="http://www.netlib.org/lapack/"
@@ -19,9 +19,9 @@ S=${WORKDIR}/LAPACK
src_compile() {
cp ${FILESDIR}/Makefile SRC/Makefile
cd SRC
- FC="g77" FFLAGS="${CFLAGS}" make static
+ FC="g77" FFLAGS="${CFLAGS}" make static || die "make failed"
}
src_install() {
- dolib.a SRC/liblapack.a
+ dolib.a SRC/liblapack.a || die "dolib failed"
}